We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question

Decimal separator in Calc (mac OsX 10.7) [closed]

asked 2012-05-05 11:27:27 +0200

Andrea gravatar image

updated 2020-07-12 23:56:44 +0200

Alex Kemp gravatar image

Hi, in my locale (italian) the default decimal separator is comma (,) both for numeric and currency formats. In the preference pane I changed numeric separator to point (.) since this setting is a standard in the scientific community and kept the comma (,) for currency. Unfortunately Calc is not able to seemly accept this setting (...like MSExcel does!) In fact it seems that in Calc one is "forced" to use locale settings "as a whole" without customizations. In there a way to work this around? Thanks. Andrea

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-10-23 02:06:50.474535

3 Answers

Sort by » oldest newest most voted

answered 2013-02-22 09:30:51 +0200

qubit gravatar image

Hi @Andrea,

Sounds like you may want to file an enhancement bug and provide as much information about this new feature as possible. Don't forget to mark your bug as an 'enhancement'. The QA team will be happy to help you triage your feature request in the bugtracker.

Please post a link to any bugs you file in a comment below using the format "fdo#123456".


edit flag offensive delete link more

answered 2012-05-05 12:36:14 +0200

Pedro gravatar image

I have the same problem in Portuguese ;) You can select cells for currency and select menu Format, Cells, tab Numbers, Language Italian (Italy)

The only limitation is that when you type currency values you must not forget to use the comma from the text keyboard instead of the point from the numeric keyboard.

(This works under Windows XP Pro x86, but I assume it should work in a Mac since it is a general configuration)

edit flag offensive delete link more

answered 2012-08-25 10:04:44 +0200

lovecraft22 gravatar image

You need to set Italian (Swiss) as you language in Libre Office.

edit flag offensive delete link more

Question Tools


Asked: 2012-05-05 11:27:27 +0200

Seen: 1,451 times

Last updated: Feb 22 '13