Ask Your Question
0

delete Times Roman fonts from Libreofice in Ubuntu

asked 2020-05-27 13:13:16 +0200

Jarratt gravatar image

updated 2020-07-19 00:22:51 +0200

Alex Kemp gravatar image

I am new to Ubuntu and using version 20.04. I have tried unsuccessfully to install Times Roman fonts in Libreoffice. The installation seemed to be successful, but at the end the <ok> button was greyed out so I couldn't click it. Maybe I clicked "no" in the question half-way though the installation instead of "yes". I have forgotten. I should now like to delete the fonts, if they are there, and start again but do not know where the fonts may be located. Would it be best to delete Libreoffice and then re-install from scratch and the try again to install the fonts? Sorry for such a silly qustion !?

edit retag flag offensive close merge delete

Comments

1

Fonts are not installed in applications but in the OS. LO uses whatever font is installed in the system.

How did you install LO? With apt-get or its GUI equivalent? How did you install the font? With a specific installer?

Always use the installer which comes with your distro. This same installer provides for disintalling packages. It will also take care of all dependencies.

Comment to provide additional information. Answers are reserved for solutions.

ajlittoz gravatar imageajlittoz ( 2020-05-27 13:53:49 +0200 )edit

Fonts are not installed in applications but in the OS

This general rule has exceptions sometimes. One is LibreOffice :) Portable builds for windows actually provide a couple of fonts in their directories. Of course, this is not relevant for the discussed case.

gabix gravatar imagegabix ( 2020-05-27 14:50:02 +0200 )edit

Thanks for the reply. 1) Yes, to install I used the usual apt-get command. 2) To uninstall, I browsed the web and ended up using what appeared to be a good source but used an unbelievably long command. I quote it here: $sudo apt-get remove fonts-opensymbol libreoffice libreoffice -* openoffice.org-dtd-officedocumenrt1.0 python* -uno.uno -lib-3* ure -debug. 3) I didn't use a distro. I downloaded from the official website and burnt an iso file onto a DVD.

Jarratt gravatar imageJarratt ( 2020-05-29 11:35:07 +0200 )edit

Spelling mistake in copied command..........! Sorry

Jarratt gravatar imageJarratt ( 2020-05-29 11:40:26 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-05-28 20:31:50 +0200

ml9104 gravatar image

updated 2020-05-28 23:42:44 +0200

System-wide fonts are stored in subdirectories of /usr/share/fonts/truetype (or opentype or type1 or...). Each typeface has its own subdirectory, eg, Arial or Times, containing the font files (normal, bold, italic etc.).

Necessary permissions: Font subdirectories: 755 root:root, font files: 644 root:root

They need to be be cached to work correctly, this applies both to newly installed or newly removed fonts. Run this command:

sudo fc-cache -f -v

This should bring your fonts up to date.

LibreOffice will normally use the system-wide fonts.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-05-27 13:13:16 +0200

Seen: 227 times

Last updated: May 28 '20