Ask Your Question
0

LO3.5.3 Writer Spell Check doesn't work [closed]

asked 2012-05-07 00:35:07 +0100

terrykiwi83 gravatar image

updated 2020-08-03 00:12:56 +0100

Alex Kemp gravatar image

SO am trying to set the spell check language in Libreoffice 3.5.3 writer and am having no luck. Just doesn't want to work.

I click on Tools > Language > For all text...

And nothing happens....

I have also tried just going to Tools > Spelling & grammar -When I do this in the language it is blank, it says spell check at beginning of document I click yes then it closes down.

forgot to mention running Ubuntu 12.04 LTS x64

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by manj_k
close date 2013-11-20 18:26:53.850509

10 Answers

Sort by » oldest newest most voted
1

answered 2012-06-11 05:09:34 +0100

trixtah gravatar image

This may well be related to the issue that OO has with non-US or UK English dictionaries. I was having the same problem with NZ English selected, but as soon as I swapped the document language to UK English, spellcheck worked fine.

English language settings that may be problematic are the following:

Australia Canada India Jamaica New Zealand Philippines South Africa Namibia Zimbabwe Trinidad

Personally I think they should leave these out if they don't work. It's pretty confusing. (Although maybe the date and currency localisation and so on works ok.)

edit flag offensive delete link more

Comments

That has been fixed in LibreOffice 3.6.0.0.beta2. → https://dl.dropbox.com/u/19264180/LibO/language_modules_en_360beta2.png

manj_k gravatar imagemanj_k ( 2012-06-26 14:24:35 +0100 )edit

And broken again in 4.1.2.3

mikro2nd gravatar imagemikro2nd ( 2013-11-20 09:52:18 +0100 )edit

@mikro2nd – Please file a new question for version 4.1.2.3 (with a more detailed description).

manj_k gravatar imagemanj_k ( 2013-11-20 18:25:05 +0100 )edit
0

answered 2012-06-13 09:15:16 +0100

hjp gravatar image

I deleted the profile directory and restarted LibreOffice. It created a new profile directory and then the spell check is working.

edit flag offensive delete link more
0

answered 2012-06-26 10:15:08 +0100

Same problem on Win7 64bit. Using Australian dictionary. On-the-fly checking doesn't work, but a manual scan does.

I seem to remember this all working on an older version, not 100% sure

I'll try deleting the profile directory (if it exists in Win7). Otherwise I think using the UK dictionary

edit flag offensive delete link more
0

answered 2013-01-18 22:34:47 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

My experience is with the Canadian version of the extension posted, as of 2013-01-18, at http://extensions.libreoffice.org/extension-center/american-british-canadian-spelling-hyphen-thesaurus-dictionaries/folder_contents

The spell check fails to detect American spellings as incorrect. The extension that fails is kpp-canadian-english-dictionary-674277-word-list.oxt

This is fixed by removing the noted extension, deleting the libreoffice config (there's a way to remove just the dictionary pollution, but I don't know it)
rmdir -rf ~/.config/libreoffice

I installed an earlier version of the extension I had around named Canadian_English_spellchecking_hyphenation_thesaurus--en_CA_2_0_0____2008-07-02.oxt

Spell checker now works as desired.

The extension does not appear to be findable with google. I did find a reference to it in the DVD listing from libreoffice. http://libreoffice-na.us/dvd__3.3.3__file-list.pdf

I will leave it up on dropbox for a couple of weeks or so.
https://dl.dropbox.com/u/46218832/Canadian_English_spellchecking_hyphenation_thesaurus--en_CA_2_0_0____2008-07-02.oxt

the technical bits: "Ubuntu 10.04.4 LTS" 2.6.32-45-generic #102-Ubuntu SMP Wed Jan 2 22:38:04 UTC 2013 x86_64 GNU/Linux LibreOffice 3.5.7.2 Build ID: 350m1(Build:2)

edit flag offensive delete link more
0

answered 2012-11-06 08:00:09 +0100

I have libreoffice 3.6.2.2 installed in ubuntu 12.10. I had the same problem with English(Canada). I went to check to English (UK) and noticed that their is an icon indicating the availability of dictionaries for each language under "tools->options->Language Settings->Languages. I switched to Engligh (UK) which had a dictionary installed and spell check began working. Later I noticed that there is an [extension available with US, British, and Canadian Dictionaries] (http://extensions.libreoffice.org/extension-center/american-british-canadian-spelling-hyphen-thesaurus-dictionaries). I installed the extension, restarted libreoffice, and was able to switch back to English (Canada), which now showed a dictionary icon, and spell check worked properly.

There may be other extensions available...in other languages to install the dictionary that you need.

I understand what Libreoffice is doing now, but it would make sense if the developers added a warning in the spell checker stating that "no dictionary is available for this language" or something similar.

edit flag offensive delete link more
0

answered 2012-06-11 05:08:43 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

This may well be related to the issue that OO has with non-US or UK English dictionaries. I was having the same problem with NZ English selected, but as soon as I swapped the document language to UK English, spellcheck worked fine.

English language settings that may be problematic are the following:

Australia Canada India Jamaica New Zealand Philippines South Africa Namibia Zimbabwe Trinidad

Personally I think they should leave these out if they don't work. It's pretty confusing. (Although maybe the date and currency localisation and so on works ok.)

edit flag offensive delete link more
0

answered 2012-06-08 11:40:44 +0100

I have just noticed the same problem with 3.5.4.2. I also noticed that when I did a manual spell check, the window that was displayed had NO language associated with the text document I was checking!!! I checked the Properties for the document and there seems to be nowhere to set the language. Could this be the problem? How does LibreOffice know in what language the document has been written so that it can carry out the correct spell check?

edit flag offensive delete link more

Comments

"How does LibreOffice know..." · (1) Menu Tools → Language · (2) Status bar (3rd field from left); right-click · (3) Help (F1), LO Writer → Tab 'Find' → Search term: language → 'Selecting the Document Language ' etc. · (4) WikiHelp → http://help.libreoffice.org/Common/Selecting_the_Document_Language

manj_k gravatar imagemanj_k ( 2012-06-26 15:10:23 +0100 )edit
0

answered 2012-05-23 22:03:03 +0100

Sorry same problem. LibreOffice 3.5.3.2 Ubuntu 12.04

edit flag offensive delete link more
0

answered 2012-08-09 19:23:29 +0100

I had similar symptoms in LO3.5.5 for Mac OSX - I fixed it by resetting the language in the preferences:

  1. Select Tools>Languages>For All Text>More...
  2. In the Options-Language Settings-Languages window, map sure you have the correct dictionary selected
  3. Uncheck For the current document only
  4. Click OK

My symptoms went away and the spell check started working as expected. I don't know why this worked but it's worth a shot...

edit flag offensive delete link more
0

answered 2012-06-12 20:22:55 +0100

same problem Libreoffice 3.5 on window xp

edit flag offensive delete link more

Comments

Question Tools

4 followers

Stats

Asked: 2012-05-07 00:35:07 +0100

Seen: 21,088 times

Last updated: Jan 18 '13