Ask Your Question
0

Impress file moved - images no longer showing. How do I fix? [closed]

asked 2013-11-01 13:39:16 +0100

Optiker gravatar image

I have an Impress document with a number of images. Originally, the images were in folder A relative to the Impress document in Folder B. I've moved B to a new folder location C, but left A in the same original location in the file structure. The images are no longer shown in the document, but now there is a place holder box and the original image file address in large red text superimposed on the Impress document text boxes.

I have also copied the entire folder structure, image folder and document folder, to a different computer, and also to a thumb drive. In both cases, the result is the same...no images.

I assume this is a case of relative versus absolute file addresses?

How do I fix it - either get the document to recognize the new relative image addresses (best solution) or clear the place holder boxes and red image addresses so I can re-insert the images (poor alternative, but will do if necessary and possible). The worst case is, re-generate the document entirely! :(

Thanks! Optiker

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-12 20:32:21.786143

1 Answer

Sort by » oldest newest most voted
0

answered 2013-11-04 07:22:11 +0100

oweng gravatar image

How did you insert the images? It sounds like they are linked rather than embedded. The easiest way to fix this is to unzip the ODP (change the file extension to ZIP if necessary), open context.xml, perform a find / replace on all instances of draw:object xlink:href="path/to/the/file.jpg" or similar, then re-add content.xml back to the archive.

edit flag offensive delete link more

Comments

I inserted using the "from file" icon in the drawing toolbar.

What zipped ODP file are you referring to?

Thanks! Optiker

Optiker gravatar imageOptiker ( 2013-11-07 19:27:25 +0100 )edit

All ODP are ZIPped files. Just change the file extension as I indicated and it should open in your archive manager.

oweng gravatar imageoweng ( 2013-11-08 07:11:42 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2013-11-01 13:39:16 +0100

Seen: 195 times

Last updated: Nov 04 '13