Ask Your Question
0

LO insists on opening text file with Calc [closed]

asked 2013-11-01 22:45:06 +0200

RonJohn gravatar image

updated 2015-11-12 20:38:52 +0200

Alex Kemp gravatar image

Hi,

There's a .txt file that I want opened in Writer, but -- as mentioned in the Subject -- LO refuses to do so. How can I force Writer to open it?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-12 20:39:04.048455

Comments

What is your operating system, LO version, and what does the text file contain i.e., delimited content, HTML? A plain TXT file should open in Writer rather than Calc, even if via the right-click context menu.

oweng gravatar imageoweng ( 2013-11-01 23:42:47 +0200 )edit

Duh, sorry. LO 4.1.2 on Xubuntu 13.04 The file contains a text that can easily be interpreted as numbers delimited by spaces.

RonJohn gravatar imageRonJohn ( 2013-11-03 11:57:25 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2013-11-04 03:05:30 +0200

oweng gravatar image

What does $ file -bi <your_file.txt> return? It should show text/plain; charset=us-ascii but if it shows something else then the file may be getting interpreted as something other than text. If it does show "text/plain" then run this command:

$ xdg-mime query default text/plain

That will indicate the default application associated with that particular MIME type. You can change it by executing:

$ xdg-mime default writer.desktop text/plain

Do not do this as root.

edit flag offensive delete link more

Comments

$ file -bi x.txt text/plain; charset=us-ascii

$ xdg-mime query default text/plain mousepad.desktop

The file is the output from the command: $ cal 2014 > x.txt

RonJohn gravatar imageRonJohn ( 2013-11-04 07:28:07 +0200 )edit

mousepad.desktop? That seems odd. Did the second command fix it? Right-click and selecting Writer certain opens up that type of text file under Crunchbang 11 here OK.

oweng gravatar imageoweng ( 2013-11-04 08:41:55 +0200 )edit

I run Xubuntu, so Mousepad is the default text editor. No, I haven't tried that solution, because I still want mousepad to be the default text editor.

My question is, "How do I tell LO to open this text file with Writer instead of Calc?"

RonJohn gravatar imageRonJohn ( 2013-11-04 13:57:39 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2013-11-01 22:45:06 +0200

Seen: 185 times

Last updated: Nov 04 '13