Ask Your Question
0

Quotation marks in Writer [closed]

asked 2012-05-08 02:07:30 +0200

zorbama gravatar image

updated 2012-05-10 15:35:54 +0200

Hello everyone!

Today, when using Writer, I saw that the double quotation marks are acting weird when I enable switching quotation marks in autocorrect options: the autocorrect only affects quotation marks that come after letters or after another quotation mark and a space. Here's a picture:The background is slightly orange because of Ubuntu's screenshot selection tool, please ignore that.

What can I do about this?

I can't think of any more details to add, but please tell me if I forgot something.

Thanks in advance!

-Amir

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-16 00:17:35.431264

1 Answer

Sort by » oldest newest most voted
0

answered 2012-05-10 05:23:13 +0200

oweng gravatar image

A sample graphic showing the issue would help as from your description I cannot tell exactly what it is you are having difficulty with. According to Wikipedia Hebrew and English now use the same form of quotation mark. The alternate Hebrew form of quotation mark only differs in the closing mark, using either a Single Low-9 Quotation Mark (U+201a) or a Double Low-9 Quotation Mark (U+201e).

I would imagine that so long as the language is set correctly, and the auto-quotation mark settings are turned on, it should adapt as required. Obviously if you are dealing with a document containing both English and Hebrew and quotation marks of both types you are going to need to set the language according to the content in question.

edit flag offensive delete link more

Comments

After trying out a few things for a while, I realized that I didn't see what actually happens in English, and it's the same. I'll edit the question title to better reflect the situation and add a picture.

zorbama gravatar imagezorbama ( 2012-05-10 15:23:57 +0200 )edit

Tools > AutoCorrect Options... > Localized Options tab is where this behaviour is set. Make sure all the replacement characters are correct (by clicking on the quote button). I use an international keyboard and do not see this behaviour under either v3.4.6 or 3.5.3.2.

oweng gravatar imageoweng ( 2012-05-11 00:54:26 +0200 )edit

After changing the characters used for the option, it does indeed work. It's a shame you can't define special characters for separate languages, but it works. Thank you for your help. :)

zorbama gravatar imagezorbama ( 2012-05-11 01:32:13 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2012-05-08 02:07:30 +0200

Seen: 3,093 times

Last updated: May 10 '12