Ask Your Question
0

Weird Kerning Between Korean Characters and Latin/Numerals

asked 2020-06-13 13:25:29 +0100

mujjingun gravatar image

updated 2020-06-15 02:28:02 +0100

image description

When I type numerals or Latin characters and Hangul (Korean) right next to each other, with no space between, LibreOffice Writer shows them as if there is a space between. This is very frustrating for me.

In comparison, below is the same text with the same font in Leafpad, which does not have this problem.

image description

How can I remove the space between the letters and the numerals?

Here is the problematic text btw: 11월 7일 Latin을

edit retag flag offensive close merge delete

Comments

Your screenshot was taken with View>Formatting Marks disabled. It is then impossible to tell if an extra qpace was added or Writer chose to space the language blocks.

Please edit your question to attach a file corresponding to your screen shot. This will be easier to diagnose the problem.

ajlittoz gravatar imageajlittoz ( 2020-06-13 14:47:13 +0100 )edit

@ajlittoz,

The extra space was not manually added. Try with this text: "1한국어" or "a한국어".

Shows correctly in the Preview Field of the Character dialog.

It replicate in Impress and Draw; not in Calc. I can't find why.

LeroyG gravatar imageLeroyG ( 2020-06-14 22:35:44 +0100 )edit

@ajlittoz, edited to include the formattting marks.

mujjingun gravatar imagemujjingun ( 2020-06-15 02:28:45 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-06-15 09:51:47 +0100

ajlittoz gravatar image

Using an answer though this is no solution to the problem.

In the screenshot, you have spaces before all numbers (except 7) but this is not the whole story.

I experimented with the strings provided by @LeroyG (after configuring LO for Asian text (to make sure).

When text is made of an homogeneous sequence (Korean only or Latin only), glyphs are set next to each other as defined in the font.

But it seems Writer handles change from Latin to Kroean script or Korean to Latin in the following way:

  • Some sort of "guard interval" is added to the last character of the sequence

    S(select one character to see the bounding box highlighted. This box is enlarged on the right side, whether it is a Korean or Latin glyph.

  • This "guard space" seems to be intrinsic to the glyph and is therefore not controlled by kerning

    The only thing you can do is enlarge even more the gap, not reduce it.

  • LeafPad is not a document processing application but a text editor, meaning it does no justification or other formatting at all. Text is displayed "raw" without any tweaking on the glyphs.

    KWrite, another text editor, has the same rendering as LeafPad, which confirms the behaviour originates in Writer handling of script change. I did not check if the same occurs when transition from Latin to Arabic, Chinese or Indian scripts.

Note: I had exactly the opposite problem when a site of mine was translated into Chinese. For aesthetic reason, I wanted spaces around Latin words. But context was different: HTML (akin to LeafPad) instead of Writer.

If the design in Writer is wrong according to Korean typographic rules, you should file a bug report giving full reference to the "standards" and attaching a short sample file.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer) or comment the relevant answer.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-06-13 13:25:29 +0100

Seen: 54 times

Last updated: Jun 15