Ask Your Question
0

How to get calc to recognize input as date, not text, and format accordingly? [closed]

asked 2013-11-14 00:46:39 +0200

samandiriel gravatar image

I used to be able to enter a date in the format MM/DD and it would be recognized as a date, and as such formatted to whatever the date format set for that cell had been set to (for example, YYYY-MM-DD). (eg) I would enter 10/1, hit enter, and the cell (having a DATE format) would change it to 2013-10-1

Now, however, it just leaves it as text instead of converting it to a date. Very frustrating. How can I change this behaviour to what it used to be / what I want?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-14 16:20:58.984357

2 Answers

Sort by » oldest newest most voted
0

answered 2013-11-14 23:05:09 +0200

Pedro gravatar image

updated 2013-11-17 17:25:46 +0200

@samandiriel, I can confirm that formatting a cell as English (Canada) does cause that problem. It is indeed a bug and since it used to work, it is also a regression. I loaded a few versions back and found out that the last version that worked as expected is 3.5.7

You can get an "old" installer from http://downloadarchive.documentfoundation.org/libreoffice/old/

It would be great if you could report this bug at https://bugs.freedesktop.org/enter_bug.cgi?product=LibreOffice

Hope this helps ;)

edit flag offensive delete link more

Comments

1

Poop. Thanks for all your work in tracking down the last working version. Bug filed at https://bugs.freedesktop.org/show_bug.cgi?id=71664

samandiriel gravatar imagesamandiriel ( 2013-11-16 00:35:49 +0200 )edit

@samandiriel, thank you for reporting the bug. Bug confirmed in the tracker.

Pedro gravatar imagePedro ( 2013-11-17 17:26:33 +0200 )edit

I am currently using version 5.0.3.2 of LibreOffice and this issue has not been resolved yet. My language settings are what they should be, but calc does not accept DD/MM/YY input for dates. Because the / is in many lap-top keyboard settings on a very handy place for this function - a lot handier than the "-", which is next to the numbers you have to type in anyway - I do miss this feature badly.

janhaverkamp gravatar imagejanhaverkamp ( 2015-11-27 13:57:32 +0200 )edit
0

answered 2013-11-14 01:00:42 +0200

Pedro gravatar image

This is probably related to the language settings. If the cells are formatted for a language that doesn't use / as a separator then Calc will assume it is text.

You can check the language for a cell in Format > Cells > Numbers tab, on the top right corner.

Example: my Language is set by Default to Portuguese and the Portuguese date separator is a hyphen - instead of a slash / So typing 1-10 will display a date but 1/10 will be formatted as text.

Hope this helps!

edit flag offensive delete link more

Comments

The language is set to "Default - English (Canada)". Using "-" instead of "/" makes no difference (ie, entering "1-10"); the input is still not converted to a date, but stays as text.

samandiriel gravatar imagesamandiriel ( 2013-11-14 19:39:05 +0200 )edit

Can you confirm whether or not the date format MM/DD exists in your version of Calc? Right click in an empty (virgin) cell and select 'Format Cells' and scan through the Numbers tab entries for it...

zimmer gravatar imagezimmer ( 2013-11-17 22:16:21 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2013-11-14 00:46:39 +0200

Seen: 6,620 times

Last updated: Nov 17 '13