Ask Your Question
0

writer export to PDF has no text

asked 2020-06-27 18:34:06 +0200

chillies gravatar image

updated 2020-07-10 10:39:14 +0200

Alex Kemp gravatar image

Version: 6.4.4.2 Build ID: FreeBSD ports 6.4.4 CPU threads: 8; OS: FreeBSD 12.1; UI render: default; VCL: qt5; Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB Calc: threaded

Hello,

Libreoffice Writer export of anyfile type to PDF results in a blank PDF. This has just started happening, with this version. I have removed and rebuilt Libreoffice, and have deleted ~/.cache/libreoffice, tried creating another user and logging in as that other user and the problem persists, and I don't know of what else to do. cups-pdf and cups are installed. No issues rendering PDFs with xpdf, just those PDFs generated by export directly-to-pdf or export-pdf in Libreoffice.

edit: not sure if it's relevant, but have noticed that if a large textfile (.odt) is loaded and let's say it's three pages of A4 long, the conversion-to-pdf is also over several (blank) pages.

I'm hesitant to blame the problem on the OS or other installed programs as I understand Libreoffice is able to handle PDF (and epub) export natively? The last working version was 6.3.6

edit retag flag offensive close merge delete

Comments

LibreOffice uses poppler for PDF export.

Mike Kaganski gravatar imageMike Kaganski ( 2020-06-28 22:04:35 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-06-28 23:11:44 +0200

chillies gravatar image

updated 2020-06-28 23:13:28 +0200

Here's a workaround for the time being:

env SAL_USE_VCLPLUGIN=gen libreoffice &

or, as I also have kf5

env SAL_USE_VCLPLUGIN=kf5 libreoffice &

but qt5 (also installed) doesn't work

edit flag offensive delete link more

Comments

This is either bug 125234 or bug 130149. The kf5 backend internally uses qt5 and basically just adds some additional, non-qt KDE / Plasma integration.

The main difference: it uses Cairo for text "processing", instead of native Qt.

You can enable this with SAL_VCL_QT5_USE_CAIRO=1.

If it's the latter bug, you use some currently unsupported font format, where the workaround is to use an other font.

jmux gravatar imagejmux ( 2020-07-04 11:01:37 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-06-27 18:34:06 +0200

Seen: 77 times

Last updated: Jun 28