Ask Your Question
0

What are these weird character writer display ?

asked 2020-06-27 22:32:20 +0200

learn_office gravatar image

updated 2020-07-11 22:06:16 +0200

Alex Kemp gravatar image

Problem : I copied content from a web page. But libre writer displays some weird space characters.

  • What are they?

  • How to remove these?

  • How to avoid these in future documents?

Weird characters

edit retag flag offensive close merge delete

Comments

1

How to avoid these in future documents?

Just don’t paste third-party stuff to your files.

gabix gravatar imagegabix ( 2020-06-27 23:19:03 +0200 )edit

Found the text you had copied online, Did a copy and paste into a html editor and viewed the html source. this is that character>>>   a non-breaking space. Mystery solved! ;)

AdmFubar gravatar imageAdmFubar ( 2020-06-28 00:42:19 +0200 )edit

Excellent.@AdmFubar

learn_office gravatar imagelearn_office ( 2020-06-28 09:50:49 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-06-27 23:05:46 +0200

RGB-es gravatar image

Most probably, they are "protected spaces:" for some reason many web pages have them all over the place. Don't worry about the gray background, because it do not print nor will be exported to PDF. If you want to eliminate those spaces from your document, select one, copy it and use the Search&Replace tool to turn them into normal spaces. If you want to not introduce them in the first place, try pasting "without formatting" (Ctrl Shift Alt V).

edit flag offensive delete link more

Comments

  1. There is no such thing as protected spaces (or is there? Educate me, what are they).
  2. Based on the screenshot, one can only guess, what they are (share a file, not a screenshot!). My guess: non-breaking spaces.
  3. If my guess is correct, Ctrl + Shift + Alt + V is useless, as it is not about formatting.

But yes, there is nothing to worry about.

gabix gravatar imagegabix ( 2020-06-27 23:18:10 +0200 )edit

You are right "Based on the screenshot, one can only guess, what they are (share a file, not a screenshot!). My guess: non-breaking spaces.". I will post file next time.

learn_office gravatar imagelearn_office ( 2020-06-28 10:10:33 +0200 )edit
1

@gabix

  1. Non-breaking spaces. Continuous switching between Spanish, Italian and English in a low caffeine environment has its consequences, it seems.
  2. That's why I started by saying "most probably"
  3. Did you try? In html non breaking spaces are represented by  , but when you copy paste html text containing such code into Writer you get two distinct behaviors: "normal paste" gives a non-breaking space, but "paste without formatting" gives a normal space. To test this, go to bugzilla, open any ticket and copy the whole line containing the bug number and the subject: between the word "Bug" and the bug number there is a   code, try pasting that line into Writer in all possible ways.
RGB-es gravatar imageRGB-es ( 2020-06-28 18:27:33 +0200 )edit

Indeed, when I tried to paste a text containing a non-breaking space from Konqueror to LibreOffice Writer as text without formatting, it was replaced with a conventional space. I was wrong (with RTF/DOC/DOCX files it did never happen), but the wrong is actually on the LO side: a character is a character and must not be replaced with another character. Theoretically.

Anyway, thanks for the pointer.

gabix gravatar imagegabix ( 2020-06-28 20:48:21 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-06-27 22:32:20 +0200

Seen: 46 times

Last updated: Jun 27