How do I get automatic spellchecking to restart?

asked 2020-06-29 02:58:28 +0200

Auto-spellchecking has been working fine until today. I expect that I have hit some magic key combination and now it does not. I think perhaps the link to standard dictionary(ies) is(are) missing but I don't know how to fix that if that is the case. I tried re-installing LibreOffice 6.4.4 with standard settings but this had no effect. If it is relevant things I type in this detail box seem to be spell checked, just not in LibreOffice.

edit retag flag offensive close merge delete

Comments

In the menu check that Tools | Automatic Spell Checking SHIFT+F7 is highlighted.

The spellcheck can only work for languages there are dictionaries for. If your document (or part of) is in English (NZ) which you don't use and don't have dictionary for, then change the language in your document to your default language, e.g. English (USA) then click in menu Tools | Language | For All Text | English (USA) or Reset To Default Language . If None is selected then spell check will not happen.

If a new document has a different language than the one you want then go into Tools | Options | Languages and change Default Language for Documents to your preferred default, in the example that would be English (USA), you should see an icon of a tick with ABC next to it. If you don't see that icon you might have to download a dictionary ...(more)

Earnest Al gravatar imageEarnest Al ( 2020-06-29 04:28:38 +0200 )edit

Thanks! I had been trying various things in Tools | Options | etc. but missed Tools | Languages and this seems to work now. Don't know how this would have changed (or why it also seemed to effect my backup: OpenOffice)

AlanPinck gravatar imageAlanPinck ( 2020-06-29 11:57:32 +0200 )edit