Ask Your Question
0

Changing default paragraph doesn't work for new documents

asked 2020-07-01 00:19:05 +0200

theleitmotif gravatar image

updated 2020-07-01 01:52:51 +0200

I am trying to change a default paragraph setting for new OpenDocument Text documents. I went through the process as found on the web..

  • created a document, changed the paragraph setting to my desired one via the Format Tab, saved it as a template
  • made that template the default

I also went into Styles via F11, edited the default style to the new setting.

If i go into templates and open the one i created (which shows the green tick to show it's the default), it has the desired settings, both through the Format Tab and the default style through Styles. But when i create new documents they don't have this setting!

I'm lost!

I've tried restarting the computer and still no joy.

edit retag flag offensive close merge delete

Comments

@theleitmotif,

Open the default template, and check if the Default Paragraph Style remain as you changed.

If you want to add more information, you can edit your question. Do not use Answer to comment.

LibreOffice 6.3.6.2 (x86); OS: Windows 6.1

LeroyG gravatar imageLeroyG ( 2020-07-01 00:59:00 +0200 )edit

You might need to change the Paragraph Style in Styles | Manage Styles or click F11. Changing Default Style should change the style for inherited styles,such as Text Body. Right-click on Default Style and select Modify... In the Organiser tab you can see Next Style and Inherit from, maybe the Next style shown isn't the one you expect? The Font, Alignment. Indents & Spacing, etc. tabs will change what you expect.

If you want to change just one style then right-click on that style and select Modify... or change your paragraph to what you want and at the top rightclick the drop down arrow and select Update Selected Style. There is more detail in https://documentation.libreoffice.org...

Earnest Al gravatar imageEarnest Al ( 2020-07-01 01:20:00 +0200 )edit

Hi, I've added some more info above. I changed the default paragraph style in the template I created through F11. Again this change also stays when i re-open the template, but new documents don't have the desired setting.

Not sure where the "Organiser" tab is, next style and inherit from, or if that's still needed.

theleitmotif gravatar imagetheleitmotif ( 2020-07-01 01:37:19 +0200 )edit

In the sidebar, right-click on the style in the paragraph style pane and select Modify... A new dialog window will open with many tabs. This is where you need to make the changes.

BTW please change your tag to Writer from Common

Earnest Al gravatar imageEarnest Al ( 2020-07-01 01:43:30 +0200 )edit

How are you creating a "new document" ?

robleyd gravatar imagerobleyd ( 2020-07-01 01:50:04 +0200 )edit

I went into templates, selected edit my template, clicked on the Default style in paragraph style pane and selected modify. The change I wanted is listed there. In the Organiser Tab the next style is the same Default Style, it is inherited from None

theleitmotif gravatar imagetheleitmotif ( 2020-07-01 02:00:12 +0200 )edit
1

i was creating a new document by right clicking on the screen and creating a new document. But when i go into Writer and open a new document the change i wanted is there! Which is kinda great, but why is this not happening when i right-click to create a new document?

theleitmotif gravatar imagetheleitmotif ( 2020-07-01 02:02:50 +0200 )edit

And trying to change the tag from common to writer is going to drive me insane. I tried retag, but it doesn't let me just type "Writer", and neither will it let me select from the dropdown list (of which Writer is not an option)

theleitmotif gravatar imagetheleitmotif ( 2020-07-01 02:04:24 +0200 )edit

@theleitmotif,

To retag, once you writed/selected "write" and deleted "common", pulse Enter twice.

LeroyG gravatar imageLeroyG ( 2020-07-01 02:13:37 +0200 )edit

@theleitmotif,

On which screen do you right click? On the Desktop? What operating system are you using?

LeroyG gravatar imageLeroyG ( 2020-07-01 02:19:50 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2020-07-01 08:00:37 +0200

ajlittoz gravatar image

You didn't mention your OS name, but I bet it is Windows.

Windows has a "glitch" (does it qualify as a bug?).

When you right-click and choose "create new Writer document" (or equivalent, I have no Windows), Windows does not send the right information to LO and the LO-default template is selected instead of the user-configured user-default template.

To make sure your template is used, launch first LO and use File>New>Text Document.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

PS: please retag your question from common to writer, add default-template.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-07-01 00:19:05 +0200

Seen: 32 times

Last updated: Jul 01