Ask Your Question
2

Why is the recent documents list empty in 3.5? [closed]

asked 2012-02-20 21:39:57 +0200

anonymous user

Anonymous

updated 2015-10-16 02:06:15 +0200

Alex Kemp gravatar image

I have upgraded from the last LibreOffice to 3.5 today. After working a while I noticed that the recent documents list in Libre Office 3.5 is not working. It stays empty however many documents I save. I really would appreciate any solution for this issue. I've tried everything with no success. Thank you.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-15 22:52:49.513930

6 answers

Sort by » oldest newest most voted
1

answered 2012-02-21 14:48:32 +0200

cloph gravatar image

updated 2012-03-06 13:07:54 +0200

https://bugs.freedesktop.org/show_bug.cgi?id=46074 and/or https://bugs.freedesktop.org/show_bug.cgi?id=46172#c1

Remove registrymodifications.xcu / the corresponding entries from that file and it should work again.

edit flag offensive delete link more

Comments

Thank you! I've modified the registrymodifications.xcu and everything works fine now :-)

Moonlight gravatar imageMoonlight ( 2012-02-21 19:10:55 +0200 )edit

fdo#46074 fixed in LibreOffice 3.5.1

manj_k gravatar imagemanj_k ( 2013-03-25 14:15:48 +0200 )edit
0

answered 2012-04-18 19:33:14 +0200

Linux Mouse's answer also works for LO running in OS X. The user directory is located in ~/Library/Application\ Support/LibreOffice/3/user. After you remove the registrymodifications.xcu or move the user directory, your recent list will be populated as soon as you open a file, save and then close it.

edit flag offensive delete link more
0

answered 2012-02-22 18:14:03 +0200

Same problem, and no apparent fix for it.

Have followed recommended install procedures, removing all traces of earlier working version of LibreOffice, and then clean install. In desperation, I have again gone through the same loop clearing everything as per advice, and clean install. Still no recent documents.

I note that when earlier version was installed using synaptic package manager there was a directory .libreoffice in /home/username. As far as I can determine the fresh install of 3.5 does not seem to use .libreoffice; or create it, if it is not present.

Any explanations, ideas?

Running Debian Squeeze - AMD 64

edit flag offensive delete link more

Comments

LibreOffice 3.5.0 now uses ~/.config/libreoffice instead of ~/.libreoffice

cloph gravatar imagecloph ( 2012-02-23 15:28:45 +0200 )edit
0

answered 2012-03-02 04:35:33 +0200

Libre Office 3.5 keeps its config files now in ~/.config/libreoffice/3/user rather than ~/.libreoffice/3/user. I copied the registrymodifications.xcu file from the previous folder to the .config/libreoffice/3/user folder and this worked. I have now my Recent Documents list OK. This also fixes other little bugs, check this website: http://www.mjfox.ch/wordpress/libreoffice-3-5-small-bugs-in-released-version-template-exists-and-recent-documents/

edit flag offensive delete link more
-2

answered 2012-02-21 13:47:04 +0200

the d gravatar image

I have the same problem on Ubuntu 11.10

edit flag offensive delete link more
-2

answered 2012-02-21 13:52:03 +0200

Mark12547 gravatar image

updated 2012-02-21 22:30:27 +0200

I have the same problem. LibreOffice Writer 3.5.0 running under Windows XP SP3.

UPDATE: Renaming the user directory LibeOffice in C:\Documents and Settings\username\Application Data solved both the Recent Document bug and the opening a template bug.

edit flag offensive delete link more

Comments

This effectively makes unavailable other important files in the user profile.

MagicFab gravatar imageMagicFab ( 2012-03-06 13:08:42 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2012-02-20 21:39:57 +0200

Seen: 4,115 times

Last updated: Apr 18 '12