Ask Your Question
0

Script capital m

asked 2020-07-10 10:06:10 +0200

Daniel Volinski gravatar image

Hi All,

I'm trying to put a script capital m, ℳ, from https://graphemica.com/%E2%84%B3 in a math formula. I proceed as was instructed in a previous question of mine. I write 2133 in the math window, select the number and press Alt-x. In the math window I see a script capital m, but in the text itself I see a regular capital M, perhaps sans serif, but is not a script capital m.

Please advice

Daniel Volinski

edit retag flag offensive close merge delete

Comments

1

This is likely a font designation problem. Please attach a document with the formula.

ajlittoz gravatar imageajlittoz ( 2020-07-10 10:41:49 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2020-07-10 10:55:05 +0200

keme gravatar image

The appearance in the Math code pane does not propagate to the formula rendering.

You can make a new token for the symbol you need. When you have defined it, the token is entered in the code with a leading %, e.g. %Mscript

See help page.

edit flag offensive delete link more
0

answered 2020-07-10 12:04:26 +0200

ajlittoz gravatar image

updated 2020-07-10 18:36:07 +0200

This is the result of my experiment:

image description

I first modified Format>Fonts so that the font for Text is a script one. I type the "formula" a b c "a" "b" "c" "2133", i.e. a sequence of variable names and free text. The last string was Alt+X'ed so that it becomes SCRIPT CAPITAL M.

As can be seen in the screen shot, the formula line correctly displays the script symbol because it does not interpret the formula (it only displays its "code") and uses some full monospace unicode font. In Writer, the formula is completely interpreted: variables names are in Liberation Serif (default) and text for a, b and c are in the script font. BUT, this script font (as is common in this font category) only offers a reduced number of characters (roughly the ASCII set; ISO-8859-x extension is not present). Consequently, U+2133 is not inside and Writer tries to find some substitute. Fonts normally advertise their family (Serif, Sans, Mono and others) so that rendering engines can look for installed fonts offering the missing glyph in the same family before falling back to any font with the glyph..

I don't know which substitute font was chosen; obviously, it is not the same design as my script font. It may be Liberation Sans, not sure about it.

EDIT Workaround

Since the problem is in the font(s) not having glyphs in the Unicode block starting at U+2100, you must use a font offering the glyph at some other position.

As mentioned above, I have a cursive font installed on my system. It covers only ASCII. Consequently, I'll use LATIN CAPITAL LETTER M instead, taken from this cursive font.

  • First, change font assignment in Format>Fonts (in Math). Push button Modify and select Serif (this is one of the Custom Fonts assignments, thus it does not break standard formula formatting). Choose a font from the proposed list. OK, OK.

  • In your formula, replace the 2133 Alt+X with font Serif {"M"}

The M will be displayed in the font you assigned to category Serif.

Note: it is important to enclose the M inside double quotes to force text interpretation. Without the quotes, M is considered a variable and italics is applied which could give a weird aspect to the glyph. A cursive font is already heavily ornamented; there is no point adding more effect which could degrade readability.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer) or comment the relevant answer.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-07-10 10:06:10 +0200

Seen: 126 times

Last updated: Jul 10 '20