We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
0

How to control number formatting in Writer Tables

asked 2020-07-17 22:09:14 +0200

theprof07 gravatar image

I'm trying to make a table in LibreOffice Writer 6.4.4.2 on Pop_OS. I want the numbers to have thousands separators. In one cell it just acts like text and I have no trouble adding commas as desired. In another cell of the table it is automatically eliminating the comma every time I try to type it. I know how to handle this in Calc. I can't find any documentation on how this works in Writer. The closest I could find is a help page for Writer that says "Choose Tools - Options - LibreOffice Writer - Table, and select or clear the Number recognition check box." I unchecked it but it didn't help. The same help page also claimed that one could right-click the table's cell to control Number Recognition but I see no such option.

edit retag flag offensive close merge delete

Comments

Did you select one of the tables styles (Default Style, Academic, Box List x..., Elegant,...) when creating the table in Writer? If yes - which one? Background of the question: These tables do have predefined formatting of their cells - e.g. Academic style table has Text formatting for row and column headers and Number formatting for all other cells as per default, while the Default Style has Text formatting for all of its cells.

To change the format: Select one or more cells and go to Table -> Number Format and define the format of your cells (quite similar to Calc).

Opaque gravatar imageOpaque ( 2020-07-17 22:39:30 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-07-17 22:43:42 +0200

Lupp gravatar image

Number formatting in TextTable is a mess. However, there is a way, but strangely not via the context menu of a CellRange or of single cells, but via the main menu item >Table>Number Format....
You may insert this submenu item also to the mentioned context menu via >Tools>Customize.

Anyway you need to know a bit about NumberFormat codes to make use of the feature.

Otherwise you can enter anything looking like a number as a text if you make sure that for your table the option >Table>Number Recognition is disabled completely (all cells).

(By the way: The usage of the comma as a group separator for numbers is explicitly deprecated by international standards.)

edit flag offensive delete link more

Comments

thanks so much! I missed that item on the menu. Was mostly looking under the Format menu.

theprof07 gravatar imagetheprof07 ( 2020-07-17 23:50:37 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-07-17 22:09:14 +0200

Seen: 515 times

Last updated: Jul 17 '20