We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
0

How to prevent flagging of repeated dashes as misspelled words in Writer? [closed]

asked 2020-07-19 16:10:08 +0200

CraigG58 gravatar image

updated 2021-05-27 10:46:23 +0200

Alex Kemp gravatar image

When writing tablature for guitar, it’s common to use repeating dashes to represent strings. Is there a way to stop Writer from flagging these as misspelled, yet still leave AutoCorrect on?

I've tried:

  • Selecting "Ignore all", which works, but the flags reappear the next time the document is opened. There is no option presented to add them to my dictionary.

  • Adding one through ten repeating dashes to the AutoCorrect options “Exceptions” tab, even though for some reason only two or three repeats are being flagged.

It’s probably something dumb I’m overlooking, but any suggestions would be much appreciated!

image description

image description

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2021-05-27 10:46:47.643928

1 Answer

Sort by » oldest newest most voted
1

answered 2020-07-19 16:18:47 +0200

ajlittoz gravatar image

Unless you changed the default colours, the wavy underline is blue not red, denoting a grammar warning, not a misspelling mistake.

AFAIK, Writer does not offer any out-of-the-factory grammar checker. This is likely provided by an extension.

Disabling grammar check either through deactivating the extension or unchecking Check grammar as you type in Tools>Options, Language Settings>Writing Aids should fix the problem.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer) or comment the relevant answer.

edit flag offensive delete link more

Comments

I never noticed that color change, thanks much for pointing it out.

But, I don't remember installing any extensions. I'd attach a screenshot of my Extension Manager, but there's no option to upload an image in comments here.

As far as the dashes go, that did the trick! Again, I appreciate your assistance.

CraigG58 gravatar imageCraigG58 ( 2020-07-19 16:41:21 +0200 )edit

Extension manager tells that there is a grammar checking by default for the English spelling dictionaries, hyphenation rules, thesaurus and grammar checker (Marco A.G. Pinto).

Opaque gravatar imageOpaque ( 2020-07-19 16:46:16 +0200 )edit

I see that, but there's absolutely nothing ticked in that extension’s options dialog.

CraigG58 gravatar imageCraigG58 ( 2020-07-19 16:59:33 +0200 )edit

@CraigG58 - my commented was referring to the statement:

AFAIK, Writer does not offer any out-of-the-factory grammar checker. This is likely provided by an extension.

Sorry for the confusion.

Opaque gravatar imageOpaque ( 2020-07-19 17:02:21 +0200 )edit

@Opaque: I never succeeded in activating grammar check (it is not disabled in Writing Aids). I doubt that my English skill is so high that I never make a mistake. I have installed the extra language package for English variants (notably for en_UK I prefer over en_US) but I don't get grammar check. What am I missing?

Installed packages (Fedora): autocorr-en hunspell-en hunspell-en-GB hunspell-en-US hyphen-en libreoffice-langpack-en mythes-en

Question 135537/how-to-enable-grammar-check-on-libre-writer/ references https://libreofficehelp.com/enable-automatic-spelling-grammar-check-libreoffice-writer/ which does not seem to be a TDF site. It suggests to install Grammarly which is not a TDF extension.

I'd like a "pure" LO solution.

ajlittoz gravatar imageajlittoz ( 2020-07-19 17:02:37 +0200 )edit

@ajlittoz

I'd like a "pure" LO solution.

that's what I tried to express but did not elaborate my comment. What I wanted to say: I have a pure TDF LibreOffice rpm-package installation (currently 6.4.5.2 on openSUSE 15.2, not using distro packages), and I have a fresh user profile (i.e. no changes, no extension installed and no modification to the profile) and I get the same observation as stated in the question. Then I read your answer, which I'd have fully agreed to one hour before, and then checked inspired by your answer, where grammar checking (in that special case) might come from. That's all...

Opaque gravatar imageOpaque ( 2020-07-19 17:15:15 +0200 )edit

@CraigG58: please, tell me how many items you have in Tools>Options>Language Settings. I only have two: Languages and Writing Aids. If a grammar checker is installed (wherever it comes from), there should be a third item. Thanks in advance.

ajlittoz gravatar imageajlittoz ( 2020-07-19 17:26:54 +0200 )edit

@ajlittoz: I have those two, plus one more called "English Sentence Checking". Perhaps that's due to the entire document being configured for "English (USA)"? At any rate, there are numerous tick boxes in there, but once again absolutely nothing is selected.

CraigG58 gravatar imageCraigG58 ( 2020-07-19 19:43:17 +0200 )edit

@CraigG58: considering what is said in the libreofficehelp.com article, I suspect this comes from Grammarly. It may have been installed unbeknownst to you. What is your OS? What was your installation method?

ajlittoz gravatar imageajlittoz ( 2020-07-19 20:50:39 +0200 )edit

@ajlittoz: Windows 10 64-bit… Did a straight install with the default options using the LibreOffice MSI file from: https://www.libreoffice.org/download/...

CraigG58 gravatar imageCraigG58 ( 2020-07-19 21:09:25 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2020-07-19 16:10:08 +0200

Seen: 55 times

Last updated: Jul 19 '20