Ask Your Question
0

Why typing with ibus-unikey make some part of words dissappear?

asked 2020-07-27 15:37:10 +0200

Tam Nguyen gravatar image

I use ibus-unikey to type Vietnamese in LibreOffice Writer. While typing, I noticed some words, their part disappeared sometime. This haven't happened in gedit. So I recorded this bug, by typing a simple word, tôi multiple times with ibus-unikey. To get tôi, you need type 't', 'o', 'o','i', '<space>'.

Errors occured at the beginning of the video and at 6 sec.

Is there solution for this?

Using Debian Buster and

Office Writer: Version: 6.1.5.2 Build ID: 1:6.1.5-3+deb10u6

edit retag flag offensive close merge delete

Comments

Whatever the quality of the video, it is difficult, without any audio track, to have an opinion. Edit your question to attach a sample file.

Are you sure no AutoCorrect entry also plays some trick without you being aware of this. This would be the case if the transformation occurs when you hit Space.

ajlittoz gravatar imageajlittoz ( 2020-07-27 16:32:30 +0200 )edit

I typed repetively 't', 'o', 'o','i', '<space>', the output should be: tôi tôi tôi tôi tôi tôi .... but at the beginning of the video and at 6 second, pressing space eat two last character of the word. Resulting, "t", then I just continue typing 't', 'o', 'o','i', '<space>' repetively.

Tam Nguyen gravatar imageTam Nguyen ( 2020-07-27 18:09:25 +0200 )edit

Then if this happens when the space bar is pressed, check the AutoCorrect options to make sure there is no rule causing the deletion.

ajlittoz gravatar imageajlittoz ( 2020-07-27 18:14:06 +0200 )edit

I have disabled AutoCorrect -> While Typing functionality, but doesn't seem to have any affect. Meaning, sometime characters get removed by space.

Tam Nguyen gravatar imageTam Nguyen ( 2020-07-27 18:35:44 +0200 )edit

I tried to set language to Vietnamese. I can do so for text, but there does not seem to be any script driver in Tools>Options, Language Settings>Languages (either Asian or Complex Text Layout). Does all the transformation occur in the OS input layer? What must I install to reproduce the issue? ibus 1.5.22, ibus-gtk3 1.5.22 and ibus-qt 1.3.3 is already there. I notice there is a specific ibus-wayland. Since Wayland is still a bit experimental, it may play in the issue. What is your desktop configuration? Wayland or X.org, GNOME or another one?

ajlittoz gravatar imageajlittoz ( 2020-07-27 18:59:21 +0200 )edit

I use Debian Buster's Gnome Desktop (default). Display manager is gdm3 To type Vietnamese:

  1. install ibus-unikey: apt install ibus-unikey . (My version is ibus-unikey/stable,now 0.6.1-1.1+b1 amd64 [installed])
  2. Add Vietnamese (Unikey) as input source: "Settings" => "Region & Language" => Add Vietnamese (Unikey)
  3. Now you can type Vietnamese in any application by changing the language icon on the top right corner (or with shortkey : Windows-button + Space bar)

SCREENSHOT SAMPLE

While typing Vietnamese in Writer, sometime some characters get erased/swallowed after <space>. On the other hand, typing Vietnamese in gedit, terminal and browsers work normally.

Hopefully, this help you reproduce the bug.

I am not sure about this question "Does all the transformation occur in the OS input layer?", because I don't understand well how ibus works. Probably yes.

Tam Nguyen gravatar imageTam Nguyen ( 2020-07-27 21:44:29 +0200 )edit

The problem is indeed Wayland. According to this link Gnome Display Manager runs on WayLand. When I switched to e.g. Xorg, then I can type without problem.

Tam Nguyen gravatar imageTam Nguyen ( 2020-07-28 21:44:49 +0200 )edit

Please add an answer telling the issue is in Wayland so that the question appears as "answered" from the home page.

ajlittoz gravatar imageajlittoz ( 2020-07-29 07:57:26 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-07-29 09:20:31 +0200

Tam Nguyen gravatar image

The issue is the running display server is Wayland. When changed to e.g. Xorg, then I can type normally.

On Debian Buster, display server can be changed in login prompt or /etc/gdm3/daemon.conf (uncomment "WaylandEnable=false")

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-07-27 15:37:10 +0200

Seen: 23 times

Last updated: Jul 29