Ask Your Question
0

How to change the default insert date format in Writer?

asked 2020-07-29 04:11:46 +0200

bwp123 gravatar image

I've searched for a week or two with no luck. In Writer, How can I set the default date insertion format to one of the choices on the list? I have projects in which each entry must be entered with a fixed date in the format NNNNMMMM DD, YYYY. We can select this from the list every time; but the only options there are "help" "ok" and "cancel". There is no "set as default" option. I would change this on the main template if I could. But it doesn't give me that option either.

edit retag flag offensive close merge delete

Comments

If you are using a template for your projects then edit the template and enter the date field in the format you want. With the cursor in the position you want the date to appear click Ctrl+F2, in the window that opens choose the Document tab, under Type choose Date, under Select choose Date (fixed), under Format choose your preferred format. Save the template. When you create a new document from the template today's date will be there in your format.

If you are not using templates then you might want to consider how you can improve your workflow by using templates. There are some good reasons in for using templates in this freely downloadable book https://designingwithlibreoffice.com/... (no connection to me except as a reader of it) Cheers, Al

Earnest Al gravatar imageEarnest Al ( 2020-07-29 05:10:46 +0200 )edit

thank you for the reply. ...We have no choice but to use templates. The entire structure of this word processor is based on templates that are extremely difficult to change. I tried for two weeks to change the default template, the normal template, numerous times. If we cannot set the parameters on that easily, then the word processor has failed. I feel this is the single most basic need of an ordinary user who does not want to spend the rest of his life reading manuals, and interrupting the writing process by struggling against the word processor. Word was like that as well, but managed to eventually engineer intuitive ways to set a number of defaults without a new engineering degree. LibreOffice though, has a far more resistant and overly-complex, not user friendly interface. I wish it weren't so..

bwp123 gravatar imagebwp123 ( 2020-08-06 07:31:55 +0200 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2020-07-29 08:39:39 +0200

updated 2020-07-29 08:42:03 +0200

Create an autotext.

  1. Insert the field into a clean paragraph without direct formatting; set it up to your liking.
  2. Select it, and use Tools|AutoText... (Ctrl+F3).
  3. Type some name like "DateField" into Name; for the name I suggest, the Shortcut will auto-suggest "D".
  4. Click AutoText ▼ button in the bottom, then New.

Now you may type D (the shortcut you chose above) anywhere then press F3, and insert the field formatted as you set up.

edit flag offensive delete link more

Comments

(Spoken aside)
...and prefer ISO 8601 format YYYY-MM-DD if not urgently forced to do otherwise.

Lupp gravatar imageLupp ( 2020-07-29 11:18:46 +0200 )edit

Thank you, all who answered, very, very much. I'm very happy with these solutions. They are very much appreciated. Excellent job!

bwp123 gravatar imagebwp123 ( 2020-07-29 21:44:20 +0200 )edit

I don't prefer YYYY-MM-DD in journals and in writing pending new writing pieces "in progress". Why must we forced to use that format? Sometimes, in some instances, frequently updated writing requires the days of the week; Monday, Tuesday, etc.in addition to day month and year.

bwp123 gravatar imagebwp123 ( 2020-08-06 07:42:02 +0200 )edit
0

answered 2020-07-29 10:04:34 +0200

GrahamLees gravatar image

Right click on the Date field in your template > Edit Fields... and select the format required from there.

Save your template and next time of opening click on the field and enter the date which will be presented in the format required.

image description

edit flag offensive delete link more

Comments

Thank you for your reply. With this, you can use the shortcut ("edit the field' and use the F keys) and LO will insert July 28th or whatever forever. In August, in September... until next year, it will ALWAYS be July 28th. It does not insert today's date; it has saved as "date field" a single day's date; the day I last saved the field. Thus inserting a date via shortcut cannot be used. I've tried it again... and will see if repetition is the charm this time. I don't suppose I will know until after midnight!

bwp123 gravatar imagebwp123 ( 2020-08-06 07:38:30 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-07-29 04:11:46 +0200

Seen: 349 times

Last updated: Jul 29 '20