We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
2

LO 7.0 breaks dll. Error in VCRuntime140_1.dll, LO starts no more! [SOLVED]

asked 2020-08-07 19:51:11 +0200

Tyco72 gravatar image

updated 2020-08-10 09:39:37 +0200

Help! I have tried LibreOffice 7.0 and then I uninstalled it because also this version doesn't fix a very bad bug, opened in 2014. There are big problems with HTML tags: https://bugs.documentfoundation.org/s... https://bugs.documentfoundation.org/s...

After the uninstallation, no other version of LO works! I can install older versions, but when I start LO, it says:

"VCRruntime140_1.dll could not be found".

In Wndows/system32, exists a file "vcruntime140.dll" But it looks that In the LO installation something says to use the "140_1.dll", which doesn't exist! If I add a copy of the dll and I rename it as "vcruntime140_1.dll", the following error comes:

"The procedure- point "__CxxFrameHandler4" has been not found in vcruntime140_1.dll" So what is LO looking for?

I have also used a vcruntime140.dll from a PC where LO works, but it doesn't help. LO has broken something. I don't know whether I can install again LO7.0, but anyway I need to find an older version which is not affected by that bug about the HTML tags. I have Windows7, but it should have nothing to do with it. Before I installed LO7.0, there were no problems with dll

edit retag flag offensive close merge delete

Comments

Mike Kaganski gravatar imageMike Kaganski ( 2020-08-10 10:27:36 +0200 )edit

Thank you for the info!

Tyco72 gravatar imageTyco72 ( 2020-08-10 20:23:55 +0200 )edit

Also breaks Firefox

broose gravatar imagebroose ( 2020-08-18 19:17:49 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2020-08-10 09:38:20 +0200

Tyco72 gravatar image

Hello, thank you. In my other working installation there was no "VCRruntime140_1.dll". There was "VCRruntime140.dll", and it didn't work the same.

Now I have downloaded the VCruntime package again here: https://support.microsoft.com/de-de/h... I have installed the "vc_redist.x64.exe", on Win7 64bit

Now it looks fine, fortunately. By now I will never install a new version of LO on my main PC, without to test its installation/uninstallation on a secondary HD.

If someone uses LibreOffice to paste inside of the same paragraph, formatted text with bold, underline, text color and hyperlinks, for example into a Wordpress page, he should switch to a very old version of LibreOffice. Try to paste such formatted paragraphs into a "Prefomatted block" in Wordpress or view its HTML content and you will see what a mess LibreOffice does. You see it also directly in the content.xml file of the document. You doesn't need to use Wordpress.

This bug is well known since 2014, and is still not fixed. Instead to design always more discolored and flat icons, they should fix such huge bugs as first. LibreOffice is making me regretting even Office 365. I am extremely disappointed. I am wasting so much time because of this bug.

edit flag offensive delete link more
0

answered 2020-08-07 21:17:49 +0200

Tramaz gravatar image

Copia el archivo vcruntime140_1.dll de otra aplicación y copiala en la dirección de LibreOffice, a mi me funciono. Lo leí en este hilo:https://ask.libreoffice.org/es/question/258866/imposible-instalar-libreoffice-solucionado/

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-08-07 19:51:11 +0200

Seen: 1,378 times

Last updated: Aug 10 '20