Ask Your Question
0

How do I permanently configure the default font for future documents?

asked 2020-08-26 06:38:49 +0100

ijustwanttoaskaquestion gravatar image

updated 2020-08-27 19:34:30 +0100

I want my new documents to open with my preferred font. I have tried altering the font settings as listed in various tutorials, such as going to Tools -> Options -> LibreOffice Writer -> Basic Fonts (Western), changing the fonts, and applying the settings. This only seems to work for each individual document, and will not carry over to new documents.

UPDATE

I figured out how to create a Template, but it only seems to work when I create a Writer document from the LibreOffice Launcher in my Start Menu. The template is also set to be the default template.

Windows Button -> LibreOffice -> Writer Document.

It does not work if I create a Writer document by right clicking the desktop, selecting new, and selecting OpenDocument Text.

Right Click Desktop -> New -> OpenDocument Text.

I am currently using Windows 10. I have also noticed that when I create a document through the start menu it is titled "Untitled 1" and if I create a document by right clicking the desktop it is titled "New OpenDocument Text."

UPDATE

Apparently this is related to Bug 133661.

I am still unsure as to how to proceed from here. It seems I need to fix the shell menu, which seems like a pretty advanced fix. All I wanted was to open a document with my preferred font.

edit retag flag offensive close merge delete

Comments

4

Settings in Tools|Options|LibreOffice Writer|Basic Fonts (Western) affect both current document and default settings used for creation of new document when no custom template is used.

Mike Kaganski gravatar imageMike Kaganski ( 2020-08-26 07:21:11 +0100 )edit

I'm pretty sure I'm not using a custom template and this still isn't working.

ijustwanttoaskaquestion gravatar imageijustwanttoaskaquestion ( 2020-08-26 17:34:06 +0100 )edit

I'm pretty sure I'm not using a custom template

In fact, the New function of shell (as you described in your answer - "Right Click Desktop -> New -> OpenDocument Text") does use a kind of template (a static document from a directory inside LibreOffice installation).

Mike Kaganski gravatar imageMike Kaganski ( 2020-08-27 10:14:20 +0100 )edit

2 Answers

Sort by » oldest newest most voted
3

answered 2020-08-27 07:12:39 +0100

The problem is caused by using "Right Click Desktop -> New -> OpenDocument Text" for creation of new documents (info missing from original problem description). This is tdf#133661, and it is partially fixed (meaning that it will consider default fonts, but not default template) in future version 7.1.

edit flag offensive delete link more
3

answered 2020-08-26 06:45:13 +0100

Zizi64 gravatar image

You must create a new Template with the desired settings, and then you need apply it as the Default template.

edit flag offensive delete link more

Comments

Or just use the created template - without applying as Default template. (Open that adjusted Template file when you want to create a new document.)

Zizi64 gravatar imageZizi64 ( 2020-08-26 06:47:25 +0100 )edit

And now I need to ask how to create a Template. Most tutorials are out of date.

ijustwanttoaskaquestion gravatar imageijustwanttoaskaquestion ( 2020-08-26 17:35:22 +0100 )edit

Just save a new, Untitled documents - what you can adjust as you want - as a Template (with .ott extension). When you open a Template, it will open as Untitled document: the link to original Template document will be broken.

Zizi64 gravatar imageZizi64 ( 2020-08-26 18:52:55 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-08-26 06:38:49 +0100

Seen: 129 times

Last updated: Aug 27 '20