Ask Your Question
0

How to force the spell checker to UK English

asked 2020-09-05 16:51:14 +0100

Rob190 gravatar image

I have a LibreOffice Writer doc and under Tools->Options->LanguageSettings the user interface, locale setting, currency, default language for docs are all set to English(UK). However these are ignored and the spellcheck language is always English(USA). The only way I've found to change it back to UK English is to introduce a spelling mistake or find a word spelt differently in UK and US English, select the paragraph and choose 'Select Language for Selection -> Reset to Default Language'.

Selecting the style, then 'modify', then 'Font', the language is shown as English(UK).

Obviously there is another settting for the language somewhere but I can't find it. Any ideas where it might be?

Rob.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2020-09-05 17:16:57 +0100

ajlittoz gravatar image

updated 2020-09-05 17:17:44 +0100

There are at least two aspects to consider.

Dictionaries

You didn't mention your OS in the question. Packaging policy varies among OS'es.

Out-of-the-shelf LO is usually installed with only English USA (en_US). Depending on the OS, you must either install the specific English language pack (containing many variants) from the distribution repository or direct the installer to install the languages you need (notably to force installation of other English variants).

You can tell if a given language is installed if the language name has a small icon (usually depicting something like an A) at left of it in the drop-down menu.

Without the needed dictionaries and other language-specific modules like spell-checker, hyphenator, …, you can still type in the language but spellcheck, hyphenation, … will not be available.

Language definition

Language for a paragraph or word is defined in the paragraph or character style. As with any attribute, you can override this setting with direct formatting. Direct formatting is "invisible" and takes precedence over the styles. Therefore, your styles may show English (UK) but your text will be in another language. You can tell the occurrence of such an override by putting the cursor in the text and reading the current language in the bottom status bar.

Your styles inherit the default setting in Tools>Options, Language Settings>Languages provided there is no override in the inheritance chain.

One common mistake is the use of Default Style for document content instead of Text Body. Default Style is the ancestor of all other styles and its settings are forwarded to all. It is intended only to set defaults, not to be used for text.

If you have modified Default Text to set a language there, this language will cascade to all other styles. To erase the modification and revert to the original "pass-thru" state, open Default Style definition, go to the Font tab and press Standard.

CAUTION! Reset is a misnomer: it only cancels the modifications you've made since you opened the dialog. It does not reset to factory-state.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

edit flag offensive delete link more

Comments

The OS in windows 10. The UK language pack is installed. That is why 'reset to default' sets the language to UK English. I don't understand your comments about it not being installed.

Regarding 'direct formatting', that sounds a possible issue here. Is there a way to tell if direct formatting has been applied and changes the language? If direct formatting has been applied, then why does every new paragraph default to US English? Maybe I don't understand what direct formatting means. I had assumed it had to be applied manually but maybe it copies the previous paragraph or something? It's not clear to me how it is supposed to work.

Rob190 gravatar imageRob190 ( 2020-09-05 22:59:48 +0100 )edit

Direct formatting is hell. It is next to impossible to visually see if it is there. One trick is to select some part of the document and Ctrl+M. If something changes, there was direct formatting. To reintroduce what was cleared, Ctrl+Z.

Fortunately, current language at cursor position is always echoed in the bottom status bar.

When you have direct formatting and hit Return to create a new paragraph, the characters you type then are formatted with the current settings (paragraph + character styles + direct formatting as they were before Return). Entering a new paragraph doesn't remove the attributes not present in the paragraph style. This is formatting continuity.

ajlittoz gravatar imageajlittoz ( 2020-09-06 08:28:08 +0100 )edit

The status bar is showing a mixture of UK English and USA English. Some paragraphs are half and half. I just tried typing a new paragraph and the first half is UK English but following a 'soft' line break (i.e. shift-return'), it changes to USA English. I tried the 'Clear direct formatting' but it doesn't have any effect either way (i.e. no change for UK English and no change for USA English).

Rob190 gravatar imageRob190 ( 2020-09-06 21:59:06 +0100 )edit

Very strange. Can you attach a 1-page sample with the issue? A file can only be attached to a question (not to a comment). Edit your question, then press the paperclip tool.

ajlittoz gravatar imageajlittoz ( 2020-09-07 08:12:59 +0100 )edit

Well I tried but closing and re-opening the document has cured the problem, temporarily at least. Thinking about it, this has happened before. It's a large document and I tend to leave it open for long periods (> 10 days). The language issue is intermittent but it's quite likely it only appears after a period of time. It's been going on for a long time, well over a year, but I'd just assumed I hadn't set the options properly. Now I know what to look for, I'll keep track of what I'm doing and see if I can pin down what triggers the problem.

Rob190 gravatar imageRob190 ( 2020-09-07 15:34:56 +0100 )edit

Happened again just now. It appears a spurious text-style is being added. I saved the doc in fodt format. The 'x' text is UK English and the 'y' text is USA English:

xx x xxxx xxx xxx xxxxxxxx.<text:line-break/>xxxx xxx xxxx xxx soxx xxxxxxxxxx xxx xxxxx<text:line-break/><text:line-break/></text:span><text:span text:style-name="T469">yyyyyyy yyyyyyy yyyyyyy
Rob190 gravatar imageRob190 ( 2020-09-13 18:58:27 +0100 )edit

Try to find the properties of T469. This is a character style.It may be an anonymous (=direct formatting) or named style. Even if the style has a name, it receives a T999 internal name to unify direct/named formatting.

Also, are you abusing of line breaks (Shift+Enter) instead of paragraph breaks (Enter)?

ajlittoz gravatar imageajlittoz ( 2020-09-14 08:11:15 +0100 )edit

Abusing? I use shift-enter a lot to get the formatting I need.

Rob190 gravatar imageRob190 ( 2020-11-03 17:34:58 +0100 )edit

@Rob190: Warning! Shift+Enteris not a formatting instruction; it is a structuring one. It causes a line wrap without leaving the current paragraph (or opening a new one). This has strong implications as LO Writer is paragraph-based. Lines above and below the line wrap are members of the same object => they can't have separate base formatting. Semantically, there is no break in the argument development. You keep with the same topic (though you can't visually tell that for sure).

So, using Shift+Enter without a significance reason is faulty. This will play bad tricks on your back when you tune the appearance of your document. A consistent use of paragraph styles and a clear and clean paragraph structure ease the task.

ajlittoz gravatar imageajlittoz ( 2020-11-03 17:51:23 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-09-05 16:51:14 +0100

Seen: 56 times

Last updated: Sep 05