Ask Your Question
0

LibreOffice Writer: Indenting doesn't work anymore

asked 2020-09-06 06:41:59 +0100

claus_01 gravatar image

Hi,

I have an .odt document with 83 pages. I would like to indent the first line in a paragraph using TAB, but for some reason this doesn't work anymore. What can I do?

TIA,

Claus

edit retag flag offensive close merge delete

Comments

Show the file.

gabix gravatar imagegabix ( 2020-09-06 07:31:02 +0100 )edit
1

Does this happen in only one paragraph? Then, what are its properties?

The "normal" way to indent the first line of a paragraph is through attribute First line indent of the paragraph style. If consistently styled your document (which is mandatory for such a long text), you only need to customise Text Body paragraph style. You didn't use Default Style everywhere, did you?

ajlittoz gravatar imageajlittoz ( 2020-09-06 08:33:07 +0100 )edit

Your case is hopeless. You could as well have used an ASCII text editor for the same result.

I add to @Zizi64's remarks: don't use frames to add borders to paragraphs. You break text flow (frame content is outside the main text flow which can cause issues when you need strictly continuous order, like building automatic TOC. The frame content may not appear where you expect it.)

Down load the Writer Guide, read it and style your document as it should.

ajlittoz gravatar imageajlittoz ( 2020-09-06 10:11:35 +0100 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2020-09-06 23:23:19 +0100

LeroyG gravatar image

First mark those paragraph that are space-tab-dented:

  • Choose menu Edit - Find & Replace… (the same that Ctrl+H);
  • In the Find: field type ^[:space:]*|\t*;
  • In the Replace: field type @;
  • Check Regular expressions, and
  • Press Replace All.

It would add the @ character at the beggining of those paragraph. I choosed @ because it is not present in your text.

  • In the Find: field type @, and
  • Press Find All, and Close.
  • Choose menu Format - Paragraph… - Indents & Spacing tab;
  • In the First line: field type 1.25 cm;
  • Press OK, and
  • Delete (the key) to delete all @S.

Tested in LibreOffice 6.3.6.2 (x86); OS: Windows 6.1.


Add Answer is reserved for solutions.

Press edit below your question if you want to add more information; also can comment an answer.

Check the mark (Correct answer mark) to the left of the answer that solves your question.

edit flag offensive delete link more
0

answered 2020-09-06 08:56:25 +0100

claus_01 gravatar image

updated 2020-09-06 10:13:19 +0100

You didn't use Default Style everywhere, did you?

I'm afraid I did. :-(

Claus

edit flag offensive delete link more

Comments

Do not answer your own question unless it is a real answer.

gabix gravatar imagegabix ( 2020-09-06 09:04:57 +0100 )edit
1

Ohhh NO! The Office suites are not typewriters... You need use (for the more efficient working):

  • the Paragraph Styles, to formatting the paragraphs - instead of the manual (direct) formatting method)
  • the First line Indent feature inside a Paragraph Style - instead of the spaces, TABs at the first line of the paragraph ,
  • the Page Styles - for the Cover Page, for the TOC (if it is exists in your documenet)
  • the Chapter Numbering feature - if you want to create a TOC (Table of Contents) automatically
  • the enforced page breaks (Ctrl-Enter, or the relevant Menu item) - instead of lots of Enter (lots of empty parasgraphs)
  • ...and many more features which the office suites was developed for...

You MUST reformat your whole document...

Zizi64 gravatar imageZizi64 ( 2020-09-06 09:10:30 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-09-06 06:41:59 +0100

Seen: 58 times

Last updated: Sep 06