We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
0

How to hide numbering of one title?

asked 2020-09-08 14:34:55 +0200

Gustavo Pinent gravatar image

updated 2020-09-28 19:20:02 +0200

Alex Kemp gravatar image

I have this structure of titles that must appears in the Summary:

1 Title 1
2 Title 2
...
5 References

But by the rules, it must be like this:

1 Title 1
2 Title 2
...
References

However, the numbering is not defined in the Heading 1 style, the option is gray. So I toggle numbering over one title and it will all be numbered automatically, including subtitles (1.1, 1.2, ...), and including References. How do I define my numbering system in a way I can toggle off one title number as it is done in Word?

Using LibreOffice 7.0.1.2 in macOS Mojave 10.14.6, saving in ODT. This rules are official in Brazil, so it will be a helpful answer for all of us...

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
2

answered 2020-09-08 14:46:41 +0200

ajlittoz gravatar image

The Heading n family of styles is associated with Tools>Chapter Numbering to create a numbered list. As with any auto-numbered list, it is impossible to skip some sequence numbers. And this is "logical" otherwise you completely mess the sequence counter.

The trick is to include inside the TOC a paragraph which is not part of the Heading 1 auto-numbered family.

Create a "clone" of Heading 1 with a right-click on its name in the style sidepane and New.

  • give it a name in the Organizer tab, like Unnumbered Level 1
  • in the Outline & Numbering tab, select Level 1 from Outline level drop down menu
  • make sure None is the Numbering style

Press OK

Now, style your "References" heading paragraph with Unnumbered Level 1.

It will be included in the TOC without chapter number.

If you need headings at other levels, do the same for levels 2+.

As the style is derived from Heading 1, any modification you make in Heading 1 formatting will be also transferred to Unnumbered Level 1 (except, of course, the outline level and numbering style you forced in your custom style).

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

edit flag offensive delete link more

Comments

It works! But I had some troubles because of the "limit" of last title with endnotes (that's another drama), was not being included in outline, but nothing that some enter-delete (create some lines above and after delete) could not solve, so my summary is ok now. By the way, I agree with the logical issue, but because of historical reasons, the academic articles must follow these rules, the last titles as References, Apendix, etc. does not have a number, but must be in the right order in the Summary (table of contents). I am aware LO users here know the trick but thought is good to have this answer for everybody else, who knows...

Gustavo Pinent gravatar imageGustavo Pinent ( 2020-09-08 19:33:10 +0200 )edit

My "logical" remark didn't criticise the typographic rules (they are an expression of a "personality" or a result of artistic choices and LO must be able to abide by them). It was a remark about the way numbered lists are implemented in LO: avoid trying to outsmart the list engine, you will sure break it. If a paragraph is unnumbered, then apply a non-numbered style.

You can apply the style also to Appendix, etc.

About your endnote issue, attach a sample file in your other question.

ajlittoz gravatar imageajlittoz ( 2020-09-08 19:40:44 +0200 )edit
0

answered 2020-09-08 19:04:55 +0200

LeroyG gravatar image

Position the cursor in the References Heading, and press Ctrl+Shift+F12, to turn Numbering / Bullets off. Now can insert the Table of Contents, and the References Heading will show without number.

Tested with LibreOffice 6.3.6.2 (x86); OS: Windows 6.1.


Add Answer is reserved for solutions.

Press edit below your question if you want to add more information; also can comment an answer.

Check the mark (Correct answer mark) to the left of the answer that solves your question.

edit flag offensive delete link more

Comments

1

@LeroyG: although your solution is quite straightforward and (in appearance only) simple, I personally don't recommend it because it is a direct formatting. It is then vulnerable to Ctrl+M application. Also, it may cause interference with the specialised chapter sequence counter. As a general rule, avoid to fiddle with list formatting through direct formatting, except to reset the counter to 1.

Also, there is an intentional emphasis by the author (or by the typographical rule) and it is highly preferable to translate this intent in a dedicated style. With a style, the document becomes immune to Ctrl+M and the visual aspect of the paragraph (and similar paragraphs) is controlled from a single point.

ajlittoz gravatar imageajlittoz ( 2020-09-08 19:28:13 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-09-08 14:34:55 +0200

Seen: 251 times

Last updated: Sep 08 '20