Ask Your Question
0

Using styles: set first page to landscape, page two still portrait - why? [closed]

asked 2013-11-25 15:34:05 +0200

David gravatar image

Here's a behaviour which I have noticed a few times, but would like to get AskLibO's wisdom on.

I use styles fairly extensively. It was my understanding that when a 'manual' style is applied (e.g., via menu or the like), then it over-rides the style currently invoked. A few times I have set up a document to landscape on page 1, but pages >= 2 are still using portrait orientation. This is (to my mind) counter-intuitive, and always a bit of a surprise.

I think the explanation must be that I have a "First Page" style set, and only it has been affected by my manual setting of "landscape". So getting to page 2 requires another manual intervention to get landscape orientation again.

There are two questions arising:
1. Is there a way to set this manually on p. 1 so that subsequent pages WILL have the landscape orientation (do I really need to set up another template for this?); and
2. Is it worth logging this as an enhancement request (not if it's "only me", or if there's a good answer to #1).

I'm using Lib0 4.x mostly on Ubuntu flavours. Thanks for any help with this!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-19 06:01:44.601233

2 Answers

Sort by » oldest newest most voted
0

answered 2014-02-02 23:38:39 +0200

oweng gravatar image

updated 2014-02-02 23:40:03 +0200

The default behaviour for the "Landscape" page style is to have a Next Style of "Landscape". If I create a new Writer document, apply the "Landscape" page style to the first page and then continue to insert page breaks (or content), all ensuing pages are set in landscape orientation.

I think the explanation must be that I have a "First Page" style set, and only it has been affected by my manual setting of "landscape". So getting to page 2 requires another manual intervention to get landscape orientation again.

You must have set your default template to use the "First Page" page style because this is not the default behaviour. If you are applying the landscape orientation to this first page using direct formatting, then the following page will revert to the "Default Style" page style (either via manual break or content forcing) as this is the Next Style defined for the "First Page" page style.

edit flag offensive delete link more
0

answered 2013-11-25 19:59:55 +0200

L-user gravatar image

Hi, in question: http://ask.libreoffice.org/en/question/20732/i-have-a-nine-page-document-i-want-a-footer-on-page-2-3-4-5-and-7-how-do-i-do-it/ I have described how page styles are actually working. Can you please read this post and write if this solves the problem. Regards

edit flag offensive delete link more

Comments

@L-user - thanks for the link -- and that was a great answer: I up-voted :) -- but doesn't really get at my question here about manually applied formatting over-riding template styles. Thanks anyway!

David gravatar imageDavid ( 2013-11-27 09:50:17 +0200 )edit

Question Tools

2 followers

Stats

Asked: 2013-11-25 15:34:05 +0200

Seen: 1,386 times

Last updated: Feb 02 '14