We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question

How to remove leading dot from heading.

asked 2020-09-10 12:23:48 +0200

Tech101 gravatar image

updated 2021-06-14 09:49:40 +0200

ajlittoz gravatar image

Using LO/Writer 7.003.

The document has headings. The style is heading 2. The headings have a leading "." like ".First Heading" without the quotes.

There is no table of contents in the document.

I have searched the help and the Net and cannot find any info. The problem is document specific because I use headings and styles in other documents without any problems.

Here is a snip showing paragraph, the heading then paragraph.

How do I change ".First Heading" to "First Heading"?


(just enabled image display - ajlittoz)

edit retag flag offensive close merge delete


The problem is document specific

Then share the document or a sample demonstrating the problem.

gabix gravatar imagegabix ( 2020-09-10 13:07:17 +0200 )edit

I re-edited the original post to include an image.

Tech101 gravatar imageTech101 ( 2020-09-10 14:38:41 +0200 )edit

Images can only show that there is a problem, but cannot give a clue to the reason. Once again: share the file.

gabix gravatar imagegabix ( 2020-09-10 14:47:08 +0200 )edit

1 Answer

Sort by » oldest newest most voted

answered 2020-09-10 15:17:48 +0200

ajlittoz gravatar image

Only a guess without the document.

Go to Tools>Chapter Numbering.

In Position tab, you probably changed Numbering followed by Tab stop to Nothing for level 2 at least.

In Numbering tab, see if Separator Before or After contains a dot and remove it (again at least for level 2).

By the way, if your Heading 2 should be separated from preceding and subsequent text, it is much better to include this vertical spacing in Indents & Spacing tab of Heading 2 instead of using empty paragraphs. You are then guaranteed taht absolutely all your Heading 2 will exhibit the same vertical spacing (no chance to forget the top or bottom spacing) and you can tune this spacing from a single location for immediate change over the whole document.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

edit flag offensive delete link more


Chapter numbering ==> numbering tab, "Separator after" contained a dot. I removed it and the dot before the heading disappeared.

I would not have discovered that in a million years.

Thanks for your help.

Tech101 gravatar imageTech101 ( 2020-09-11 00:34:31 +0200 )edit

I need more than 5 points to upvote.

Tech101 gravatar imageTech101 ( 2020-09-11 00:38:46 +0200 )edit

You now have them as someone deemed your question "interesting" and upvoted it.

ajlittoz gravatar imageajlittoz ( 2020-09-11 07:48:56 +0200 )edit

That makes two of us. No idea where that dot appeared from. Mine was a .doc file which was changed to .odt

arkadian gravatar imagearkadian ( 2021-01-26 22:07:08 +0200 )edit

This worked for me. Same story as others - no idea how it got there & wouldn't have found solution without this page. Thanks!

ChrisMurphy gravatar imageChrisMurphy ( 2021-05-18 11:10:34 +0200 )edit

Excellent!!! Many thanks for the answer. The dot just appeared in a .doc file and even printed with them. I had no idea what it was and how to get rid of them. This page was a lifesaver.

JAGolkin gravatar imageJAGolkin ( 2021-06-14 09:35:01 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2020-09-10 12:23:48 +0200

Seen: 482 times

Last updated: Jun 14