Ask Your Question
0

How to set the default subset for 'Special Characters'

asked 2020-09-11 15:39:04 +0100

JdeP gravatar image

updated 2020-12-08 15:14:54 +0100

I haven't had an answer to my question below, so I'm updating it and hoping for a response.

I fully removed and re-installed Writer. Now I ahve a variant of the same problem: now when I go to "Insert" and choose "Special character" I get an even more limited table of available characters (see image)image description

I assume the problem must be in my saved options/prefernces somewhere, but I don't know where to find the relevant file, and whether it is safe to delete it. Help will be much appreciated!

Thanks in advance ...


[Original message:]

I recently updated to Ubuntu 20.04 (and LibreoOffice Writer Version: 6.4.5.2 Build ID: 1:6.4.5-0ubuntu0.20.04.)

With a document open, if I select "Insert" then "Special character..." the normal dialog box opens. At the top, the "Search" box is empty", the "Font" box is empty, and the "Subset" box says "Basic Latin". In the grid below, however, are two rows of mostly mathematical and punctuation characters (! " # $ % & ' ( ) * + etc.), but the rows below this are all from the Gujarati subset, not the Latin alphabet that I expect and want. I attach a screenshot.image description

I assume I have accidentally changed a default setting somewhere, but I can't imagine how, and can't find out how to change it back!

edit retag flag offensive close merge delete

Comments

Select a font in the respective list.

gabix gravatar imagegabix ( 2020-12-08 15:20:15 +0100 )edit

I get this kind of mishap on very sparsely populated fonts. After selecting a "normal" Unicode font, i.e. a font with many characters notably the most common ones and tables for replacement/substitutions, everything is back to normal.

Apparently, the dialog starts with no font selected (or rather a random pointer in its control structures). Select first a known-good font.

ajlittoz gravatar imageajlittoz ( 2020-12-08 15:53:03 +0100 )edit

Thank you very much. I thought that the font I was using was a normal one, but apparently not! By re-setting the font of the entire document to Liberation Serif, I now have access to the full range of Special Characters. Thanks to everyone who responded! Much appreciated

JdeP gravatar imageJdeP ( 2020-12-08 17:01:33 +0100 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2020-12-08 15:59:34 +0100

petermau gravatar image

Writer reuses your previous font selection if the font selection is blank. as @gabix has suggested select a font like LIBERATION SANS to provide a full charaCTER SET TO SELECT.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-09-11 15:39:04 +0100

Seen: 67 times

Last updated: Dec 08 '20