Ask Your Question
0

Why does writer bog down to a crawl when graphics are pasted into a text document [closed]

asked 2013-11-28 01:15:46 +0200

Wayne E Dixon gravatar image

updated 2013-11-28 02:06:14 +0200

m.a.riosv gravatar image

I am Wayne E. Dixon and my email address is wdixones @ yahoo.com .

                      I am writing a book and have embedded graphics or drawings from the drawings made using painting section of LibreOffice. When I copy and past from the drawing to the text document. The system { the program } crawls to a slow snail speed. I mean you type a character and have to wait an undetermined specified time before it appears. And the newest version draw crashes the system many times. And watching the taskmaster with this program running. And found with activities with draw causes the program to access more memory than it needs. And at a certain point it stops and causes libre office to issue program not responding at every click and selection. I have been using libre office since 3.3 and just updated to the latest version just a few days ago. I so far this version and the last had the similar problems. But this latest version is worse. Is there a magic way I could embed graphics into my documents without having my program crawl to a slow snail mode?

Please send me an answer to this please.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-14 23:01:59.344177

Comments

Please Wayne, what is your LibreOffice version and your operating system?

m.a.riosv gravatar imagem.a.riosv ( 2013-11-28 02:07:42 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2013-11-28 15:42:49 +0200

petermau gravatar image

I had a similar problem which turned out to be caused by my memory settings. Not a problem with a text only document.

Are your memory settings correct for the type of document your are creating? TOOLS > OPTIONS > MEMORY

The LIBREOFFICE GRAPHICS CACHE must be large enough to contain your images, and the MEMORY PER OBJECT size set to be larger than your images. Make certain that the REMOVE FROM MEMORY option is large enough. If it is set to 00:00 HH:MM the objects will be reloaded each time you press enter which will grind your system almost to a stop.

edit flag offensive delete link more
0

answered 2013-11-28 12:38:16 +0200

L-user gravatar image

updated 2013-11-28 12:42:29 +0200

Save the image, then in LibreOffice open it with Insert | Picture | From file.

Also try to size down the images to the size you need. Don't put very big image in LibreOffice if you need a small one, because whole image will get imported in LibreOffice and sized down in LibreOffice, a lot of waste of resources. Use some image editor to size down the image, before embed it in LibreOffice.

Don't know the file format you are having, try saving files in different format JPG, PNG etc and see which format produces the smallest disk space.

If using PNG, then you can use PNGGauntlet to reduce the size of the image and PRESERVE the same quality image (program just removes all that naked eye does not see, like comments in images, all sort of unneeded things...). See: http://pnggauntlet.com/

If this all does not solve the problem, then I suggest to have each chapter of your book in a new Writer document and when you book is finished then merge them back (or not depending what you need).

And one more thing... if you have some anti-virus (anti-malware or similar) installed then try do disable it to see if it conflicts with LibreOffice. I ones had a problem of non responsive LibreOffice because of an anti-* software scanning any action taken in LibreOffice and so made me lose my mind.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2013-11-28 01:15:46 +0200

Seen: 1,167 times

Last updated: Nov 28 '13