Ask Your Question
0

Urls and e-mail addresses are not converted to links

asked 2020-09-24 22:21:19 +0100

Jaap van de Putte gravatar image

I'm using LO on a Mac (10.15). In Writer I have once unchecked the option URL Recognition in Autocorrect. Then I checked the option again for M and T. But the urls and mail addresses are still not autoconverted to links. How to solve this?

edit retag flag offensive close merge delete

Comments

Which version of LibreOffice are you using?
Did you already try whether this happens while running in LibreOffice Safe Mode as well (Help -> Restart in Safe Mode)?

Opaque gravatar imageOpaque ( 2020-09-24 22:52:19 +0100 )edit
1

Only new url and internet links will be converted, ones inserted while you had conversion turned off will remain as purely text.

You can always search for @ , www, and http to find the text. There might be an easier way to convert them to hyperlinks than adding a space after them then deleting the space but that's what I would.

If you don't like the blue underlining then change the character style by right clicking on Internet style in sidebar, selecting modify and change single underline to none, change colour if you want too. Cheers, Al

Earnest Al gravatar imageEarnest Al ( 2020-09-24 23:06:07 +0100 )edit

To apply changed AutoCorrect rules to existing text, Tools>AutoCorrect>Apply or Apply & Edit Changes

ajlittoz gravatar imageajlittoz ( 2020-09-25 10:34:57 +0100 )edit

I like that better :-)

Earnest Al gravatar imageEarnest Al ( 2020-09-25 13:10:54 +0100 )edit

@ajlittoz: You wrote: "Thanks for the feedback, but this is a Question & Answer site, not a forum. To keep up with the spirit of the site, please, use the more link to repost as a comment." So should I post it here? Don't know what you mean by 'reposting' ...

Jaap van de Putte gravatar imageJaap van de Putte ( 2020-09-30 15:08:41 +0100 )edit

How can I close this item?

Jaap van de Putte gravatar imageJaap van de Putte ( 2020-09-30 15:09:02 +0100 )edit

At the bottom of your "answer", there is a row with icons+commands. One or them is labelled more (you're the only one to be able to see it). Click on it. One of the actions is "Repost as comment".

A question is considered "answered" when you click on the gray tick mark at top left of a satisfying answer. Click only once. It may take some time for the mark to turn green due to security barriers on the server, but it will turn green.

After some discussion between "regulars", we no longer recommend to formally close a question by clicking on the link below it. Closing it prevents to improve answers, should a contributor find a better way or should a new release make the accepted answer no longer operative.

ajlittoz gravatar imageajlittoz ( 2020-09-30 16:15:15 +0100 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2020-09-26 14:29:02 +0100

Jaap van de Putte gravatar image

@Opaque: Thanks. Running in save mode resulted in normal situation: urls convert to clickable urls. By the way: all autocorrect options didn't work anymore. This happened when I unchecked the option and rechecked it. Althought the checks were on (the checkbox went blue), it still functioned as it was unchecked.

In Save mode you can change some settings. I tried them but they didn't solve the problem. So finally I removed my profile and this brought the solution: it works! Now I have to reinstall the templates and the autocorrections I had. It's a bit of work, but I am happy it works again.

edit flag offensive delete link more

Comments

The test in Safe Mode is about testing whether a corrupt user profile is causing a problem. If the test results in normal behavior, then the next step is what you have performed - reset the user profile. That's why I asked that in my comment.

Opaque gravatar imageOpaque ( 2020-09-26 14:38:25 +0100 )edit

Thanks for the feedback, but this is a Question & Answer site, not a forum. To keep up with the spirit of the site, please, use the more link to repost as a comment.

Answers are reserved for solutions and this isn't one (though you confirm that resetting the profile solves the issue. @Opaque will make it a proper solution so that you can check it (thus causing the problem to be dispqyed as "solved" in the list).

ajlittoz gravatar imageajlittoz ( 2020-09-26 17:16:50 +0100 )edit
0

answered 2020-09-26 17:56:58 +0100

Opaque gravatar image

For the records (according to OP's Safe Mode test result)

To solve the issue, reset your user profile using the following procedure:

  • Start LibreOffice
  • Start in Safe Mode using Help -> Restart in Safe Mode and confirm the restart using button: Restart
  • Archive your profile expanding Advanced (click on the word Advanced right above Help button) and click Archive User Profile button
  • Select option Reset to factory settings
  • Activate [x] Reset entire user profile
  • Click button Apply Changes and Restart

(Helped according to questioner's response)

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-09-24 22:21:19 +0100

Seen: 43 times

Last updated: Sep 26