Write isn't respecting my margins

asked 2020-09-25 03:11:41 +0200

Squish80 gravatar image

I have a Writer document I'm trying to print. The document is set with .79" margins (default) all the way around and with US letter (8.5 in. x 11 in.) for the paper size, in portrait orientation. I've had no printing problems before, but tonight, I tried to print this doc, and even though the margins clearly appear as they should be both in normal view and in print preview, the output on paper is that the text runs off the bottom and off the right side of the page. I thought maybe it was my printer (an HP desk jet), but when I tried exporting the doc to a PDF to email it to a different computer to try a different printer, the output in the PDF was the same--running off the bottom and right side. So it appears this is an issue with Writer and not my printer.

What I've tried so far: removing all direct formatting, resetting everything to default (even though I was using all the default settings), and copying and pasting the text into a fresh doc.

Any suggestions?

edit retag flag offensive close merge delete

Comments

Try turning off OpenGL or Skia (depends on version, Skia in LO 7) in Tools > Options > LibreOffice > View and see if that helps, if not please comment under this comment. Cheers, Al

Earnest Al gravatar imageEarnest Al ( 2020-09-25 05:08:52 +0200 )edit

Share the file.

gabix gravatar imagegabix ( 2020-09-25 06:35:19 +0200 )edit

If you are in Windows and it is waiting to restart after an Update weird stuff can happen. Also there was an Update I had a couple of months ago that caused my printer to misbehave. It was solved after a couple of days but I can't remember how, possibly multiple reboots or updating driver.

Earnest Al gravatar imageEarnest Al ( 2020-09-26 01:03:42 +0200 )edit

Sorry for the very delayed response--life got nuts.

I've sort of figured out what's going on. My default document size is letter 8.5 x 11. When I go to print, for whatever reason, the page size shows as that until I got into Print > Properties, where it shows as letter 8 x 10. From Print > Properties, then I can click "Use only printer size from printer preferences" and pick the right letter size and then print fine. I went into my printer settings, and for some reason, 8x10 was marked as the default, which is bizarre, since I've never changed it to this. I suppose it's an issue with an update from HP, as my printer's an HP. Problem is, this change in the printer settings is not making it over to Writer, so I still have to go into the print ...(more)

Squish80 gravatar imageSquish80 ( 2020-10-16 04:06:08 +0200 )edit