Ask Your Question
1

The clipboard does not work correctly?

asked 2020-09-28 09:48:41 +0100

Frants gravatar image

updated 2020-10-27 08:16:26 +0100

The clipboard does not work correctly?

When I copy from Notepad to Writer, the clipboard works correctly. When I copy from Writer to Notepad and then from Notepad to Writer then a problem occurs. The previous Writer buffer is inserted each time! I reboot the Writer, copy it to the clipboard again, and the same problem! I could not find a clear answer how to solve this problem, help!


Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452 CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win Locale: ru-RU (ru_RU); ИП: ru-RU Calc: threaded

//---

LibreOffice 7.0.2 released but the issue is not resolved.

edit retag flag offensive close merge delete

Comments

Are you using some clipboard manager software?

Zizi64 gravatar imageZizi64 ( 2020-09-28 10:38:29 +0100 )edit

No. Additional software is not used. The same problem occurs in the Calc.

  1. I opened Writer and Notepad.
  2. I copy from Notepad and paste into the Writer : OK.
  3. The same ..: OK.
  4. I copy from Writer to Notepad: OK.
  5. Same ..: OK.
  6. Now I copy from Notepad to Writer: problem, previous buffer!
Frants gravatar imageFrants ( 2020-09-28 10:41:19 +0100 )edit

I suffered the sane issue a while back but it resolved itself soon afterwards, possibly with restart or another update. I used notepad++ during that time. I have added Paste a unformatted text to the standard icons to avoid similar issues and to save time.

Earnest Al gravatar imageEarnest Al ( 2020-09-28 13:03:48 +0100 )edit

Thanks for the help. I looked at what you recommended. I've seen such discussions before. But there I did not find a solution to the problem, only a discussion of the fact that the problem exists. It looks like Windows 10 compatibility. The reason is not Notepad. The same problem with other apps.

Frants gravatar imageFrants ( 2020-09-28 13:46:30 +0100 )edit

The same problem with LibreOffice Calc on Windows 10.0.19041, no clipboard manager software. If I copy from cell to cell it works, but if I try to copy to cell from any other app it pasts previous buffer. No workaround is found.

IgorVi gravatar imageIgorVi ( 2020-10-14 13:28:46 +0100 )edit

Emty Empty Empty

Frants gravatar imageFrants ( 2020-10-29 09:02:06 +0100 )edit

For me this problem went away as quickly as it arrived, some update must have fixed it.

You could try turning on Windows clipboard history as a workaround, at least then you could choose what to paste. Click on Start Menu > Settings > System > Clipboard and turn on Clipboard History. You can then use Win+V to view history and then choose what you want to paste. Cheers, Al

Earnest Al gravatar imageEarnest Al ( 2020-10-29 23:35:05 +0100 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2020-09-28 12:07:57 +0100

newbie-02 gravatar image

hello @Frants,

LO has some problems with the clipboard, even without clipboard manager software (which is known to make things worse),

when i tried your description in LO 7.1, win7x64, i had no fails, but instantly afterwards when i tried updating my bug-list in calc,

got a dialog box: 'the content of the clipboard could not be pasted', first time i see this,

you may look at tdf#130361, tdf#130147, tdf#129354, tdf#128740, tdf#128714, tdf#128663, tdf#62196,

perhaps you find a workaround, perhaps you can add some clue to the problem,

big(gst) issue: the bug shows up sporadic, thus it's difficult for the developers to get a handle on it ... :-(

reg.

b.

edit flag offensive delete link more

Comments

Still, the problem must be solved by the developers. The developer should definitely pay attention to this. This error causes a lot of trouble.

Frants gravatar imageFrants ( 2020-09-30 20:26:02 +0100 )edit
0

answered 2020-10-07 11:35:03 +0100

Archway1 gravatar image

Just add that I have seen the same problem since upgrading to LibreOffice 7. The problem is intermittent. I notice it with some frequency as I use Dragon NaturallySpeaking, quite often using the dictation box rather than direct dictation and it is the paste from the dictation box which fails. There is no error message; simply, nothing is pasted. However, the material exists on the clipboard and can be pasted into other applications directly with no difficulty. Curiously, once the material has been pasted into another application, pasting into LibreOffice then works.

This is occurring on fully updated Windows 10 x64 (LibreOffice x86 for compatibility with Dragon NaturallySpeaking) with no clipboard manager in place.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-09-28 09:48:41 +0100

Seen: 127 times

Last updated: Oct 27 '20