Language resets to keyboard

asked 2020-10-06 01:25:46 +0100

helel lightbringer gravatar image

The system language of my PC is English, but my keyboard is Croatian (set it like that because it's easier for me to type and I don't get confused). However, all of a sudden, my LibreOffice language will reset itself to Croatian whenever I try to type anything. This hasn't happened before.

edit retag flag offensive close merge delete

Comments

That is a setting of your paragraph style. You probably want to have some templates with English styles and some with Croatian styles.

If you right-click in a paragraph and select Paragraph > Edit Style you will see in the Font tab the default language, in your case, I suppose it says Croatian.

If you change it in Default Style to English then the subsidiary styles, e.g. Body Text, Headings, etc will pick up the language from that.

Hopefully, someone who uses two languages regularly can offer suggestions on the best way to run them side-by-side

Earnest Al gravatar imageEarnest Al ( 2020-10-06 05:30:41 +0100 )edit

What is your operating system?

gabix gravatar imagegabix ( 2020-10-06 06:42:09 +0100 )edit

It happens even when I mark down the entire document as English: the next letter I write, it switches me to Croatian.

And my system is W10, latest version.

helel lightbringer gravatar imagehelel lightbringer ( 2020-10-07 11:44:59 +0100 )edit

Then the behavior is correct. If you want to keep your text English, switch to English as the input language (you can enable a Croatian layout, but for English).

gabix gravatar imagegabix ( 2020-10-07 13:08:58 +0100 )edit