Edit footer in libreoffice writer 7

asked 2020-10-26 17:37:58 +0200

I can't seem to figure out how to edit footer in LO Writer 7.0.2.2 and have the change affect all pages. Most of the examples I can find talk about menu options that don't seem to exist in this version.

Thanks

edit retag flag offensive close merge delete

Comments

. Most of the examples I can find talk about menu options that don't seem to exist in this version.

Changes are minimal - so which operating system do you use and do you use another user interface setting than "Standard Toolbar" (i.e something like "Tabbed")?

The procedure still is:

  • Click into the footer (may be you need to add a footer by clicking on blue helpers + sign first)
  • Insert -> Field -> Page Number (if you want to add a page number, or select another Field. or add any text you want to appear on all pages).
Opaque gravatar imageOpaque ( 2020-10-26 18:12:45 +0200 )edit

I'm using Windows 10.

I think I spot the problem, when I select the footer on the first page it says "Footer - First Page" .

I can't seem to get what I type in this footer to appear on other pages, which makes sense as it does say - First Page. But how do I get just one footer that appears on all pages?

Thanks.

GreyArea gravatar imageGreyArea ( 2020-10-26 19:23:27 +0200 )edit

If you are using more than one Page Style you need to define the footer once per Page Style. So if your second page starts using Default Page Style you need to do that for this page style as well (and once for all other page styles you may use). There is a page style First Page, since very often the first page of a document should not have a footer (e.g a page number), while all others should have.

Opaque gravatar imageOpaque ( 2020-10-26 19:34:51 +0200 )edit

Can you elaborate on how to manage multiple page styles. The documentation says to Choose Format - Styles and Formatting, however in my version such an option does not exist.

I have Format > Page Style but that doesn't seem to have the options I'm looking for.

Thanks,

GreyArea gravatar imageGreyArea ( 2020-10-26 19:45:39 +0200 )edit

So I think I found the option, unfortunately comments don't allow me to upload images but if I click on the right hand side "Styles and Formatting" I can see that there's a "Default Page Style" and a "First Page" style. I can't seem to apply it, every time I click on some text in the first page and then select "Default Page Style on the right, it just reverts back to "First Page" style on it's own. This is infuirating, I hope someone can tell me what I'm doing wrong.

GreyArea gravatar imageGreyArea ( 2020-10-26 19:52:59 +0200 )edit

Why do you read Documentation for 4.1 if you are on 7.x? Here is the link to Help of Version 7: https://help.libreoffice.org/7.0/en-US/text/shared/05/new_help.html

Anyway - check View -> Styles and hover over the icons beneath the word Styles, The fourth icon should bring you to the Page Styles. Right click on a page styles -> Modify takes you to the properties of a page style. In rab Organizer you see, that a page style has an Next style, which automatically get applied, if a new page is allocated for holding new content. And you also see, that First Page has Default Page Style as Next style, while Default Page Style is always followed by itself. This all runs automatically. To force a special page style to be applied you need to use menu Insert -> More Breaks -> Manual ...(more)

Opaque gravatar imageOpaque ( 2020-10-26 20:01:35 +0200 )edit

Thanks - I seem to have finally cracked it. One thing I was missing was that I needed to double click on the page style to apply it. It is documented but I missed it.

GreyArea gravatar imageGreyArea ( 2020-10-26 21:20:44 +0200 )edit