We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question

Different sub line font in Heading 2 (added 3/4 through a book)

asked 2020-11-07 23:56:45 +0200

JUSTROB gravatar image

updated 2020-11-08 01:02:02 +0200

I've been translating a book and have set up Chapter Numbering as Heading 1 with the Chapter subject as Heading 2 which goes in the Right page header. This has been going very smoothly.

Now I get to page 165, Chapter 12, and the subject has a sub-subject below it in a smaller font (Basic Process) and in the Right page header. The sub-subject shows in the header as all caps and following a colon. The table of contents shows the sub-subject after a colon but not all caps.


I have Headings 3 & 4 being used. It is just the last two chapters so I was thinking of ignoring it but I'd like to keep with the book accuracy. Is there any way of dealing with this gracefully?

Please, see attached photo of the chapter and the attached document.

image description

C:\fakepath\A Guide for Listening and Inner-Healing ODT.odt

edit retag flag offensive close merge delete



Do you need this sub-header to appear in the summary list, in the table of content ?

Please edit the description of your question to answer this question or add-up a comment.

Kind regards, Michel

mgl gravatar imagemgl ( 2020-11-08 00:43:27 +0200 )edit

I just made the change in the post description.

JUSTROB gravatar imageJUSTROB ( 2020-11-08 01:03:36 +0200 )edit

1 Answer

Sort by » oldest newest most voted

answered 2020-11-08 08:29:18 +0200

ajlittoz gravatar image

If the sub-subject is to appear in the TOC:

  • type a line break Shift+Enter instead of a paragraph break at end of the subject. The sub-subject becomes part of the heading (Heading 2)
  • apply a character style to the sub-subject to format it differently (essentially font size and not bold apparently)

The header and the TOC will not show a colon between the subject and sub-subject.

  • add a colon at end of the subject, before the line break
  • apply a character style to the colon with Hidden attribute to make it invisible in the heading. All styling is removed when text is inserted through fields, therefore the colon appears in the header and the TOC.

If the subject must not appear in the TOC:

Leave it as you styled it (not a Heading n, but IMHO your choice of Preformatted Text is bad because it is usually intended for monospaced text).

  • add a cross-reference over it with Insert>Cross-reference, Set Reference Type
  • use a dedicated page style per exceptional chapter for right page because you'll change the header (there can be only one header per page style); basically this page style is the same as the right one for all other chapters
  • in the right header, after the field inserting the subject, type : (colon+space), then Insert>Cross-reference, Cross-Reference Type; select the cross-reference above with Reference Insert reference to

The TOC is unchanged.

I still find that your structure (outline) is twisted and your use of Heading n family does not reflect the real hierarchy of headings. You'll experience problems when you try to finalise the book. I urge you to read the chapters about styles (don't neglect character styles) in the Writer Guide and use them extensively. This is th only way to tame formatting issues in ~200 pages book.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more


That worked!

Since I want the sub-subject in the TOC the shift>enter did what I want.

But now my one last question: The sub-subject has each word just capitalized but in the Right page header the sub-subject is ALL CAPS. I looked at the header format but don't see a way to do it. I doubt it is done in Heading 2 or is it?

JUSTROB gravatar imageJUSTROB ( 2020-11-08 13:58:12 +0200 )edit

If your (sub-)subject in the text is lowercase and uppercase in the header, some sort of formatting is in effect: look in the side stylepane while the cursor is inside the field. First have a look at the highlighted paragraph style to see if it enforces a case effect in Font Effects. If none, display the character styles and repeat the procedure. Note that if Default Character Style is highlighted, no style is in effect.

Last (or first), apply Ctrl+M to the whole header to remove any direct formatting.

Tick the answer to mark the question solved.

ajlittoz gravatar imageajlittoz ( 2020-11-08 14:21:41 +0200 )edit

Before I get into that I'm having a problem adding the sub-subject shift+enter after the subject Heading 2 in Chapter 13. It won't add the line break.

I had it working but tried to put the lower case lettering into the sub-subject and it would not allow lower case letters.

Any thoughts as to why I can't add a line break after Heading 2's subject?

I will look at your suggestions now too.

JUSTROB gravatar imageJUSTROB ( 2020-11-08 14:45:19 +0200 )edit

Have you enabled View>Formatting Marks. If not and you already inserted the hidden colon, Shift+Enter is also hidden and you have no visual feedback of its presence. Shift+Entermust not have the Hidden attribute.

If your sub-subject is all uppercase in text (not in header), check some styling effect. Don't forget to Ctrl+M whole paragraph. Also you could have applied Format>Text>UPPERCASE which modifies document content. Apply Format>Text>Sentence case or Capitalize Every Word to restore initial state. My preferred is Sentence case and apply title case through paragraph style. Thus you can demote your sub-subject to body text without caring for casing.

ajlittoz gravatar imageajlittoz ( 2020-11-08 14:57:53 +0200 )edit

Ok, I have it all showing the way I want it to in that I get the different font in the sub-subject heading with just capitalization of the first words and this I did by using the shift + enter and setting the font to what I wanted.

But now, if possible, I'd like to get the sub-subject which is NOT all caps to show up as all caps in the Right page header. Is there a way to do that?

JUSTROB gravatar imageJUSTROB ( 2020-11-08 17:11:43 +0200 )edit

No. This is a limitation of field insertion. The insertion behaves as a single character and can only receive styling (or formatting) as a whole. If you don't mind having the subject uppercase too, apply uppercase to the whole field. Subject and sub-subject will both be uppercase.

ajlittoz gravatar imageajlittoz ( 2020-11-08 17:39:57 +0200 )edit

Got it! I'll be happy with first word caps in sub-subject heading.

Thank you!

JUSTROB gravatar imageJUSTROB ( 2020-11-08 17:53:42 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2020-11-07 23:56:45 +0200

Seen: 35 times

Last updated: Nov 08 '20