Ask Your Question
0

Disable Date Formatting in Calc [closed]

asked 2012-05-19 04:21:05 +0200

DV88 gravatar image

updated 2015-08-29 14:58:45 +0200

Alex Kemp gravatar image

Ok, this is driving me absolutely crazy. Any time I try to enter data in a cell with a format of, say, 7-8 (as in "7 to 8"), it keeps changing it to a date! How can I disable this permanently, forever, finito?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-07 01:47:27.221667

5 Answers

Sort by » oldest newest most voted
1

answered 2012-05-19 08:45:34 +0200

rrbd gravatar image

If I understand the question, DV88 wants to see the string "7-8" in the cell. That's easy, with 3.5.4:

a) Format cells where you want to see strings as "Text" before you start your inputs. b) If you only need that for 1 particular cell, start Input with single quote

In 3.6 the auto date recognition will be more restrictive, there (at least with my parallel installation of Master "LOdev 3.6.0alpha0+ – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 7175cee]" (tinderbox: Win-x86@6-fast, pull time 2012-05-16 22:07:37) "7-8" will not be recognized as date.

edit flag offensive delete link more

Comments

That's good to hear about 3.6. Text formatting works, but I'm using calculations in some cells and things like that in others, so having to do it for every cell is a chore and I can't just set the whole document to it. -_-

DV88 gravatar imageDV88 ( 2012-06-19 07:02:28 +0200 )edit
0

answered 2012-05-21 01:53:02 +0200

Dennis Roczek gravatar image

rightclick on the cell --> Cell format --> tab [Numbers] --> choose a preferred format!

edit flag offensive delete link more

Comments

Does not work for me. I have explicitly used the format "Numbers -> General", but when I enter 1/3, it is interpreted as a date, and not as one third.

Golar Ramblar gravatar imageGolar Ramblar ( 2019-08-08 11:44:06 +0200 )edit
0

answered 2014-12-14 15:35:38 +0200

This automatic date format drives me crazy too. With such a nice long list of possible date formats libreoffice programmers could have easily included "none". If they are going to copy excel they should not include annoyance factors like this. I'm sure there is someone somewhere who wants all their dates arranged for them but I haven't ever met anyone like that. I'm not happy to have to start every date cell on every spreadsheet with a single quotation mark. Can anyone recommend a spreadsheet program where date formats can be disabled? Many thanks.

edit flag offensive delete link more

Comments

Glad to find a comrade. Down with all silly smart features! Alas! Calc having abolished one of the internal date accepance patterns there wolud be a crowd of loudly crying and bitterly weeping users, I think. they surely will insist on their saving some seconds every other day by automatisms they're accquainted to, and won't worry about the hours others are spending on the fight against the implications. Let's hope "none" will stay excluded. (Did you visit Language settings for this?)

Lupp gravatar imageLupp ( 2014-12-14 16:17:58 +0200 )edit
0

answered 2012-05-19 04:43:39 +0200

m.a.riosv gravatar image

updated 2012-05-19 04:45:02 +0200

I think the easy way is to put a + or = at the beginning.

+7-8 or =7-8

edit flag offensive delete link more

Comments

I do not believe that that matches with reporter's needs, I understand his question how to get string "7-8" into the cell, not calculation result "-1"

rrbd gravatar imagerrbd ( 2012-05-19 08:40:25 +0200 )edit
0

answered 2012-05-20 15:50:42 +0200

1) Enter '7-8. This is same as Excel.

2) Before enter the string, set the data format as string in the range.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2012-05-19 04:21:05 +0200

Seen: 18,257 times

Last updated: Dec 14 '14