Ask Your Question
0

Keeping data together in Libre database report

asked 2013-12-31 16:01:38 +0100

Everette gravatar image

updated 2015-10-05 03:15:48 +0100

Alex Kemp gravatar image

I have created a database with member info including photo. I have checked to keep data together in option for the record on the report layout. When I do a print preview the data is being split with another page instead of forcing a page break. Is this a bug or what am I doing wrong? I am running windows 7 and latest Libre Office. HELP>

edit retag flag offensive close merge delete

Comments

1

It seems there are some bugs that might be relevant to your problem? e.g. see HERE. Are you trying to keep GROUPS together or just individual records? See this thread. Perhaps you might explain how you are setting the 'keep data together in option'.

frofa gravatar imagefrofa ( 2014-01-01 01:48:06 +0100 )edit

I am creating a report from a base file. When I layout all the fields in the report and generate it, the records are extended to next page if data wont fit on same page instead of creating page break and placing all of record on next page. I am pacing all the fields in detail tab of report and options for detail tab I have selected keep data together as yes.

Everette gravatar imageEverette ( 2014-01-13 01:03:26 +0100 )edit

Frofa The example is exactly what I am running into! Is there a fix in the works for this? I am new to LibreOffice and have been running into issues trying to get away from MS Office.

Everette gravatar imageEverette ( 2014-01-13 03:08:51 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-01-05 02:53:38 +0100

EasyTrieve gravatar image

updated 2018-01-05 07:08:41 +0100

In a Base Report design the Keep Together choice appears in two quite different places:

1) When you open the properties of any group you'll see it under the General tab. (Use View | Properties to show properties. Then left click any of the group tabs, i.e. the colored items in the left side bar, except for Page Header and Page Footer. Then you can set Keep Together in the General tab.)

2) In Sorting and Grouping it is present at the bottom of that dialog.

They don't seem to relate to each other. In other words, if you check Keep Together for a group in the Sorting and Grouping dialog, it doesn't seem to set or use Keep Together under the General tab. (I don't know if this is by design or a bug, but it sure is confusing.)

So far I can't get any of the General tab Keep Together settings to do what I would expect.

But in the Sorting and Grouping dialog if I set the Keep Together to Yes then I am able to at least get a report to break where the header is with the data.

I know that's not a great answer, but I will try to improve it as I figure out how to workaround the bugs: a) lack of documentation, and b) at least one of these is broken.

edit flag offensive delete link more

Comments

EasyTrieve gravatar imageEasyTrieve ( 2018-01-05 07:16:47 +0100 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2013-12-31 16:01:38 +0100

Seen: 879 times

Last updated: Jan 05 '18