Ask Your Question
1

How to display page number in Bengali Language in LibreOffice Writer? [closed]

asked 2014-01-05 06:11:33 +0100

Adnan gravatar image

I was trying to get the page numbers in Bengali Language in LibreOffice. I've tried by enabling CTL from Tools > Options > Language Settings > Languages. Then from Tools > Options > Language Settings > Complex Text Layout > General Options, I selected Bengali (Bangladesh) from the Numerals. At this point, not only in the footer but also in the whole document, all numbers changed in to Bengali. But my aim was to change the language to Bengali of the page numbers in the footer only, not the whole document.

In Addition I tried, to modify the Page Number character style, setting its CTL language to Bengali. But that did not change the footer numerals to Bengali number system at all!

To be frankly I did not find anything like this for LibreOffice, as there is in MS Word. So, how can I change ONLY the page numbers into Bengali Language at the footer please?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-18 11:35:31.248652

Comments

really serious. tools>options>Language Settings>Languages>Locale setting>(your language)

But it changes all the numberals to your language. LO must think of this.

Googly Googly gravatar imageGoogly Googly ( 2014-01-05 10:21:02 +0100 )edit

Not just Bengali, appropriate fields should work in any localized language as per the keyboard input type or CTL setting maybe.

ramonrails gravatar imageramonrails ( 2015-08-27 07:49:53 +0100 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2014-01-05 21:23:15 +0100

oweng gravatar image

updated 2014-01-05 23:58:10 +0100

Setting variables / fields to display in the script of a locale / language appears to be a partial implementation at present. Using v4.1.4.2 I can turn on CTL support and download / install the bn_IN language pack, but the list of available page number formats (via Insert > Fields > Other... > Document tab > Type of "Page" > Select "Page numbers") does not appear to include Bengali digits (০, ১, ২, ৩, ৪, ৫, ৬, ৭, ৮, ৯):

Page number formats

Tools > Options... > Language Settings > Complex Text Layout > General Options section > Numerals is a general setting for all numeric characters in a document and is not specific to fields, which is the problem here. IMO installation of a language pack should include the ability to readily set variables / fields in the indicated language e.g., inserting a variable by selecting Language of "Bengali (Bangladesh)" via Format "Additional Formats..." results in a Format of "Standard" being selected:

Variable formats

... which (despite the Bengali digit in the Value field) results in an Arabic numeral being displayed:

Resultant variable display

It is possible that some additional locale setting is required, however I could not get this to work. This does not appear to be a Bengali-specific issue. @Adnan has reported the bug as fdo#73302.

edit flag offensive delete link more
0

answered 2014-01-05 12:15:09 +0100

m.a.riosv gravatar image

Maybe you can find it in Menu/Insert/Fields/Others [Ctr+F2] Document - Page - Format

edit flag offensive delete link more

Comments

Sorry, but that does not help either! In Document > Page > Format, there it's no option for Bengali number system, or adding a custom number system.

Adnan gravatar imageAdnan ( 2014-01-05 13:19:49 +0100 )edit

Some bengali numbers must appear there. There are some boxes appearing. These are meant for some Devanagari other varients, numbers are missing there too. However, Bengali is yet a far cry. Some one should contribute a solution to this. Even Devanagari has the same problem.

Googly Googly gravatar imageGoogly Googly ( 2015-01-13 18:22:27 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2014-01-05 06:11:33 +0100

Seen: 1,867 times

Last updated: Jan 05 '14