We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
0

When saving a text file as odt should it use the default template?

asked 2020-11-28 16:07:23 +0200

let gravatar image

OS Ubuntu 18.04 up-to-date patches

LibreOffice 7.0.3.1

I made a new default template for Writer, three changes, font, font size and printer settings to use duplex. It works fine for new document.

I noticed that when I open a text file (.txt) and save it as an Open Document file (.odt) using Writer, it doesn't use the default template.

I wasn't expecting this behaviour so I had to reprint a few documents.

I'm guessing that since I am saving an existing document, even though it is plain text document, Writer doesn't use the default template but whatever settings the original document had.

If this is true, is there a setting I could change to make it use the default when creating a new document from a text file?

Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
3

answered 2020-11-28 16:35:12 +0200

ajlittoz gravatar image

A .txt file does not contain any formatting information. When you open it in Writer, it is used "as is". Saving it, even in .odt format will not add any formatting information beyond Default Page Style for page dimensions and Default Paragraph Style for text itself.

A template is taken into account only when creating a new document from scratch.

Even if you tweak your txt-original Writer .odt document to force a template unto it (e.g. with the TemplateChanger extension), this will not affect the document until you manually restyle it (unless Default Paragraph/Page Style were changed in the template.

The best workaround is to create a new document with File>New>Text Document. You get an empty one based on the template. Open the .txt file in a text editor. Copy all and paste into the .odt document. You may need to remove excess paragraph breaks depending on formatting in the .txt source.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

edit flag offensive delete link more

Comments

Thank you for taking the time to answer my question.

As a user who doesn't know the ins and outs of this stuff, I was surprised by this behaviour. I thought the default template was used for any new documents and, to me, by saving the text file as an odt file I was creating a new document.

Now I know the template is only used for new documents created by LibreOffice.

let gravatar imagelet ( 2020-11-28 16:49:12 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-11-28 16:07:23 +0200

Seen: 51 times

Last updated: Nov 28 '20