Ask Your Question
0

Line break after a picture with caption [closed]

asked 2014-01-05 20:54:52 +0100

P_Aleksandrov gravatar image

updated 2014-01-05 20:55:29 +0100

Sometimes Libreoffice Writer makes a line break after a frame with picture image description and sometimes not: image description Is it an occasional behaviour or not? How can I remove a line break after the frame (e. g. move the ¶ symbol to the left of the frame as in the second picture)?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-18 11:26:46.482838

1 Answer

Sort by » oldest newest most voted
0

answered 2014-01-05 22:01:49 +0100

oweng gravatar image

updated 2014-01-06 23:19:06 +0100

Thanks for providing the example. Sometimes this is a factor of the anchoring of the frame. If anchored "To Paragraph" the pilcrow (¶) will appear beneath the frame. If anchored "As Character" the pilcrow will appear adjacent the frame.

In this case however it is a strange break phenomenon that only seems to affect the pilcrow when there is not enough room for it beneath the frame. Rather than forcing the pilcrow to the next page (when at page end) or moving the position of any ensuing object (when two objects are closely positioned) LO is placing it to the right (at least for LTR text) of the frame. Graphics are also affected in the same manner and the problem appears consistently for versions back to v3.3.0.4 under GNU/Linux, so is likely inherited from OOo.

I can't find a related open bug for the matter relating to page end (although both may be the same issue) despite searching using various combinations of "picture", "image", "graphic", "frame", "wrap", and "para". Bug fdo#67997 is likely the report related to two frames in close proximity causing this behaviour. Although that report does not specifically address this issue, I would guess it is the same cause.

Please raise a new bug and include as much detail as possible. I would also recommend changing the example document to place both images / frames on a single page with a single pilcrow beneath the final image (set at page end) to demonstrate the issue. If you do raise a bug, please report the related number back in the form "fdo#123456". Thanks.

edit flag offensive delete link more

Comments

The frames on boths screenshots are anchored "To Paragraph". An example of document: https://drive.google.com/file/d/0BxFahK53mP6IaGl6UVBhZkZXb00 Version of Libreoffice: 4.1.4, Ubuntu 13.10.

P_Aleksandrov gravatar imageP_Aleksandrov ( 2014-01-06 12:06:51 +0100 )edit

Is it possible to remove an empty line after the frame (on the first screenshot)? I want to place two pictures on one page without an empty line between them (because there is no room for the empty line).

P_Aleksandrov gravatar imageP_Aleksandrov ( 2014-01-12 14:49:00 +0100 )edit

Probably only by changing the anchoring and wrapping of the frame i.e., by anchoring both frames on the page to a single carriage return and setting wrapping to none.

oweng gravatar imageoweng ( 2014-01-15 02:08:52 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2014-01-05 20:54:52 +0100

Seen: 511 times

Last updated: Jan 06 '14