Ask Your Question
0

Changing the color of special characters

asked 2020-12-04 18:48:47 +0100

lduperval gravatar image

updated 2020-12-04 20:20:56 +0100

Hi,

I want this character:

to have a different color. On Word, I can select it and change the font color and it works as expected. In LO 7, it doesn't change anything. Is this a bug? Or an unimplemented feature that I should request?

  • I am on Windows 10
  • This is LO 7
  • The font is Segoe UI Emoji
  • I insert the character using Windows+. shortcut
  • It is U+274E NEGATIVE SQUARED CROSS MARK

This is how the font color changes the appearance on Word:

image description

Thanks,

L

edit retag flag offensive close merge delete

Comments

There are THREE colors. Which one does MS something assume to be the font color?

Lupp gravatar imageLupp ( 2020-12-04 19:13:31 +0100 )edit

Works in LibreOffice 6.4.7.2 (x86); OS: Windows 6.1.

  • Type U+27AE, and press Alt+X
  • Select the glyph, and change font color

All fonts render the glyph without shape change.

LeroyG gravatar imageLeroyG ( 2020-12-04 22:50:57 +0100 )edit

Interestingly, the font shown shouldn't be Segoe UI as it is not licensed for non-Microsoft programs on non-Microsoft platforms, probably a Google substitute coloured emoji. You will be happy to know that on some platforms it will render with a red background, see https://emojipedia.org/cross-mark-but...

The cross mark that I see on your question looks like Segoe UI Symbol, Negative Squared Cross Mark, U+274E

The tick mark looks like Segoe UI Emoji, White Heavy Checkmark, U+2705

Anyway, coming to the point, an up-to-date (2004+ I think) Windows 10 system will now render Emojis in full colour. It looks like Word might be doing it wrong, you shouldn't be able to change the colour of a colour specified emoji.

How about, as a temporary measure for a few years while the specs are nailed down, using ☑ U+2611, ☒ U+2612 with appropriate highlight colours, rather ...(more)

Earnest Al gravatar imageEarnest Al ( 2020-12-05 00:24:22 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-12-04 19:11:50 +0100

ajlittoz gravatar image

Do you mean U+274E NEGATIVE SQUARED CROSS MARK?

You also didn't mention your OS, LO version and the font used.

The OTF specification is not approved yet for coloured glyphs and different OSes/font vendors handle this issue differently.

It is likely that the Dingbats glyphs are taken from a specific dedicated font, whatever the face you select. This is what happens on my Fedora 33 Linux box. Ican try and change the font face for any font installed, the displayed glyph does not change. I assume it is a "natively" coded glyph which overrides any user setting, including colour.

"Bold" does not change it. "Italic" does but I think it is simulated in absence of a variant of the font.

I don't think it is an LO bug but something related to the font renderer.

There are other "natively" coloured glyphs and they behave the same (see the emoji and the "flag" letter).

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-12-04 18:48:47 +0100

Seen: 33 times

Last updated: Dec 04 '20