Ask Your Question
0

LO 4.1.4.2 Can't associate files Win 7 [closed]

asked 2014-01-09 17:17:54 +0200

Kent Smith gravatar image

updated 2016-02-18 14:15:45 +0200

Alex Kemp gravatar image

I upgraded to 4.1.4 and the file extensions did not get associated. I did the usual methods of associating files ("Default Programs") and LO did not appear in the list of available programs. I would browse to swriter.exe or soffice.exe and select it but it did not get established as the default. I eventually uninstalled completely LO redownloaded and reinstalled. Same problem.

I can start LO from the icon, navigate to the file I want to open and it opens correctly, but I cannot click on an .odt (or any other file) and get LO to open.

Without really knowing what I was looking for I browsed the Registry. swriter or soffice were listed as defaults for the different extensions and was listed as an available application. The only thing I considered odd was that soffice.bin was also listed as a default program.

I am now stuck and very frustrated. Thanks for any help I can get!

Kent

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-18 14:15:59.005477

Comments

To add to the confusion. Thurderbird opens LO correctly when I click on an attachment...

Kent Smith gravatar imageKent Smith ( 2014-01-12 21:11:54 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2014-01-13 18:14:31 +0200

Kent Smith gravatar image

updated 2014-01-13 23:43:23 +0200

manj_k gravatar image

I seem to have stumbled on a solution, although I don't understand it.
1. I selected "Open with..." for a file who's extension did not have anything associated with it (WordPerfect) browsed to Libreoffice/program/ and selected soffice.exe.
2. Lo and behold, LibreOffice magically showed up in the Open with... option for most of the extensions that LibreOffice should be the default.
3. Some, like .odt had other programs set as the default. However, I could now go to Start/Program Defaults and change the default. (previously it refused to change or even recognize LibreOffice when selected).
4. LibreOffice now shows up in the list of available programs.

edit flag offensive delete link more

Comments

Thanks for this imaginative workaround in a particular situation. :)
That may be a help for all users in similar cases.

See also the comments here.

manj_k gravatar imagemanj_k ( 2014-01-13 23:31:38 +0200 )edit

Question Tools

2 followers

Stats

Asked: 2014-01-09 17:17:54 +0200

Seen: 275 times

Last updated: Jan 13 '14