Pressing = key types a + sign

asked 2020-12-17 00:16:18 +0200

iwritewords gravatar image

updated 2020-12-17 20:51:03 +0200

Holding Shift, the = key types a + With Caps Lock on, the = key types an =

AFAIK, this is the only key that does this. It only happens in LO, both in Writer and Calc.

Thanks!

Edit: Version: 6.4.6.2 (x64)

Edit 2:
Version: 6.4.6.2 (x64)
Build ID: 0ce51a4fd21bff07a5c061082cc82c5ed232f115
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: default; VCL: win;
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

edit retag flag offensive close merge delete

Comments

Well, that is a real puzzle, but it would be a big help if you told us which version of LO you are using and what your Operating System is. And please Edit your question above to provide this additional information, rather than using "Answer" below. Thanks.

ve3oat gravatar imageve3oat ( 2020-12-17 00:41:16 +0200 )edit

Cannot confirm on my keyboard (german quertz layout on GNU/Linux opensuse leap 15.2 system with LANG set to de_DE.UTF-8 and using LibreOffice version 7.0.4.2 (TDF packages)

Opaque gravatar imageOpaque ( 2020-12-17 00:44:28 +0200 )edit
1

That is exactly as I expect the keyboard would behave in all programs, including Notepad or other text only utility. With Caps Lock on you still have to hold Shift to get the +

Caps Lock makes letters capitalised but does not affect the functions of the other keys, e.g. 4 remains 4 when Caps Lock is on; it does not give $.

Earnest Al gravatar imageEarnest Al ( 2020-12-17 00:52:22 +0200 )edit

@ Earnest AI,

The weird thing is that having Caps Lock on is the only way I can type an = sign. Pressing the key without Caps Lock on gives a + sign.

iwritewords gravatar imageiwritewords ( 2020-12-17 19:11:20 +0200 )edit

Can you share your operating system and other LibreOffice info? To do that, choose menu Help - About LibreOffice, copy from there, press edit below your question and paste.

I'am testing with an en-US keyboard layout:

  • = gives =
  • Shift+= gives + (as you wrote)
  • CapsLock, = gives = (as you wrote)
  • CapsLock, Shift+= gives +

What happen with the hyphen and underscore key?

  • - gives
  • Shift+- gives
  • CapsLock, - gives
  • CapsLock, Shift+- gives
LeroyG gravatar imageLeroyG ( 2020-12-17 20:07:07 +0200 )edit

- - gives -
- Shift+- gives _
- CapsLock, - gives -
- CapsLock, Shift+- gives _

iwritewords gravatar imageiwritewords ( 2020-12-17 23:33:56 +0200 )edit

I don't know where to go, but in my opinion it can not be a LibreOffice issue. Just in case, take a look at the guidelines at https://wiki.documentfoundation.org/U... to see if it can be caused by corruption in the user profile.

LeroyG gravatar imageLeroyG ( 2020-12-17 23:50:28 +0200 )edit

You probably have sticky keys enabled. Search for your operating system and sticky keys to find out how to disable. If you have Windows I strongly suggest to disable the hot key that turns it on as it is a key combination that is used sometimes. Cheers, Al

Earnest Al gravatar imageEarnest Al ( 2020-12-18 01:43:56 +0200 )edit

I checked Sticky Keys and it wasn't on. I checked the problem with it on and with it off, and it didn't make a difference.

I've found out that it isn't only with LO. When I had tried it earlier, it didn't do it in my web browser, so I said that it was LO. It's now happening in my web browser.

Thank you all for your help. This thing has stumped me for a while.

iwritewords gravatar imageiwritewords ( 2020-12-18 04:18:52 +0200 )edit

Lenovo has some advice if keys aren't mapped correctly, it might be worth checking it out to see if the steps can solve your problem.

Earnest Al gravatar imageEarnest Al ( 2020-12-18 06:04:41 +0200 )edit