Ask Your Question
0

javaldx: Could not find a Java Runtime Environment! [closed]

asked 2014-01-13 22:23:04 +0100

Dor gravatar image

updated 2015-08-26 19:06:10 +0100

Alex Kemp gravatar image

Hi,

I have a Bash script that uses LibreOffice (version 3.5.7.2) in order to open a spreadsheet (calc).

The script first makes a backup of the directory ~/.config/libreoffice/3/user and creates a mount point at that path as a ramfs filesystem.
To that mount point, it creates a file named registrymodifications.xcu with content that is known in advance (it simply disable some features of LibreOffice).
Also, the file registrymodifications.xcu configures LibreOffice's temporary directory to reside on a ramfs filesystem that is mounted in /tmp, having an arbitrary name (using mktemp).

After performing this procedure, the Bash script uses LibreOffice the open the spreadsheet document. Then, the following error is shown:

javaldx: Could not find a Java Runtime Environment! 
Please ensure that a JVM and the package libreoffice-java-common
is installed.
If it is already installed then try removing ~/.libreoffice/3/user/config/javasettings_Linux_*.xml
Warning: failed to read path from javaldx

How do I solve this problem and make the error go away?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by igorlius
close date 2020-11-01 11:45:12.864447

Comments

1

Obvious question: did you try what the error message says? Do you have a JVM and the package libreoffice-java-common installed? If you do, did you try to remove the mentioned file?

bencomp gravatar imagebencomp ( 2014-01-14 22:44:18 +0100 )edit

5 Answers

Sort by » oldest newest most voted
1

answered 2014-01-27 07:42:40 +0100

ACupOfCoffee gravatar image

Load Java like it says to.

edit flag offensive delete link more
1

answered 2015-08-07 20:32:28 +0100

mifay gravatar image

I had a similar problem.

To fix this, I simply downloaded OpenJDK from Ubuntu synaptic.

edit flag offensive delete link more
0

answered 2015-06-04 01:17:35 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

If removing ~/.libreoffice/3/user/config/javasettings_Linux_*.xml doesn't work neither, you can try removing

~/.config/libreoffice/3/user/config/javasettings_Linux_*.xml

or

~/.config/libreoffice/4/user/config/javasettings_Linux_*.xml

with: rm ~/.config/libreoffice/[3,4]/user/config/javasettings_Linux_*.xml

edit flag offensive delete link more
0

answered 2019-09-30 16:46:13 +0100

vstepaniuk gravatar image

On Ubuntu 18.04 this helped:

sudo apt-get install default-jre libreoffice-java-common
edit flag offensive delete link more
0

answered 2020-03-21 14:01:29 +0100

OK I could install jre but what if I do not want to install a jre?

I have unchecked the "Use java" checkbox in Preferences.

Still I get the "failed to read path from javaldx" warning each time I start libreoffice.

My environment: fresh Xubuntu, in a virtual machine.

edit flag offensive delete link more

Comments

1

This is just a warning. How is it a problem?

Mike Kaganski gravatar imageMike Kaganski ( 2020-03-21 18:21:13 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2014-01-13 22:23:04 +0100

Seen: 29,765 times

Last updated: Mar 21 '20