Ask Your Question
0

Form control for CLOB is not working

asked 2021-01-13 13:20:37 +0100

stanton gravatar image

I have created a form for a database table using the wizard. The form uses one of the detail view layouts (one text edit control and label per column).

The table consists of three VARCHAR columns and one CLOB column. The wizard created a single-line text edit control for the VARCHAR columns and a multi-line text edit control for the CLOB one.

Now when I edit data in this form, the control for the CLOB column is empty (although the column is non-NULL). When I tab through the controls, the control for the CLOBgets skipped.

What is the correct way to have a table hold text in excess of 255 characters, and be edit it through a form?

LO 7.0.0.3 (x64) on Windows 10, Firebird DB engine.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2021-01-13 13:34:28 +0100

stanton gravatar image

The CLOBcontrol created by default is not a text box.

Select the control (enter the group so you get the control, not the group of the control and its label) and view its properties—the header shows that LO by default creates an image control, not a text box.

Right-click the control and select Replace with > Text box, save the form and you should be able to edit the CLOB. You may still need to make some manual adjustment, such as enabling line wraps (it will be a single-line control by default).

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-01-13 13:20:37 +0100

Seen: 11 times

Last updated: Jan 13