Ask Your Question
0

When in writer on some lines words are spaced way too far apart

asked 2021-01-18 10:05:07 +0200

artdevil313 gravatar image

When working in writer, I am doing some indented paragraphs. On some lines, when I begin typing the cursor moves to the end of the line and all words are spaced very far apart. As I add more words they get closer together. The problem is that if a line has only a few words, they remain very far apart. I just want every line to function the same, with uniform spacing of words.

edit retag flag offensive close merge delete

Comments

... sounds like you are using justification while you want to have left aligned text.

Opaque gravatar imageOpaque ( 2021-01-18 10:07:37 +0200 )edit
1

sounds also like you are using line breaks Shift+Enter instead of paragraph breaks Enter to mark the end of paragraphs.

Also, how do you indent? With spaces, tabs or adjusting the first line indent in the ruler?

Please do not use Add Answer but edit your original question to enhance the details of your question (answers are reserved for solutions to a problem on this Q&A site).

ajlittoz gravatar imageajlittoz ( 2021-01-18 10:19:23 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2021-01-18 12:06:23 +0200

ajlittoz gravatar image

In Writer a paragraph is a unit of text uniformly formatted. It is the extent where a paragraph style applies.

A paragraph is the text range between two Enter markers.

For formatting purposes, this text can be voluntarily split over several lines with a line break Shift+Enter. A line break does not end the paragraph. It simply means a line is forced to contain only the "words" between the previous line wrap (whether computed by Writer algorithm when flowing text or user-defined with a forced line break) which are then formatted by the paragraph style without change.

When justify is in effect, the shorter line content is still justified from margin to margin with extra large spaces.

This behaviour can be controlled with compatibility options in Tools>Options but this is very subtle and you need to be "fluent" in Writer to realise the consequences of these options.

For the time being, make the difference between paragraph break and line break.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

edit flag offensive delete link more

Comments

It is since I have been using writer, especially in lists, that I have had problems with forced justification using shift enter

It mostly happened to me using full stop and newline but remaining in the same list item forcing me to use palliatives like shift + ctrl + space or left alignment

I didn't know there was the option to disable forced justification in these cases just by using the options.

I just tried this solution and it works perfectly

Thank you very much

torreone gravatar imagetorreone ( 2021-01-18 14:12:59 +0200 )edit

Usually line breaks are bad ideas because they do not translate faithfully the semantics of your discourse. It looks more like you want to explain something for the list item. This means it is a full paragraph on its own. In case like this, add an unnumbered list item. The easiest way is to press Backspace immediately after Enter. It erases the number (or bullet) but you remain in the list. Next paragraph will resume numbering unless you again erase it.

The trick may also be applied to existing list. To transform a numbered item into an unnumbered one, put the cursor at the very beginning of the item and press Backspace.

ajlittoz gravatar imageajlittoz ( 2021-01-18 14:38:23 +0200 )edit
0

answered 2021-01-18 11:55:14 +0200

artdevil313 gravatar image

Thank you for your help.

As it turns out, the lines that were displaying the weird behavior were doing so because, as you mentioned, I was using Shift+Enter. When I went back and ended the lines with just Enter it resolved the problem. Thanks again for your help!

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-01-18 10:05:07 +0200

Seen: 29 times

Last updated: Jan 18