Ask Your Question
1

Inserted white space after a formula object [closed]

asked 2012-05-24 16:33:02 +0100

AndrewMiles gravatar image

updated 2015-10-16 04:21:47 +0100

Alex Kemp gravatar image

I am inserting formulas in Writer, using LibreOffice 3.5.3.2 on Mac OS X (Snow Leopard). I'll describe what is happening, and include formula code so that you can easily reproduce my problem.

  1. I insert a formula that takes up maybe two lines of vertical space, in this case because of the fraction (y over b = 4*r + 4)

  2. I copy the formula and paste it in later in the document, then edit it so that it only takes up one line of vertical space (y = (4*r + 4)b)

  3. I try to write directly underneath the pasted/modified formula, but I cannot. It seems that Writer is maintaining the height of the original formula object (i.e., two lines of vertical space).

How can I fix this so that I can still copy, paste, and edit formula objects? I prefer copying and pasting in this way because I do a fair amount of work that involves showing how to solve equations, which means modifying formulas one step at a time - pasting allows me to avoid having to continually insert new functions and retype the formula code.

Thanks!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-16 04:21:57.109979

1 Answer

Sort by » oldest newest most voted
1

answered 2012-05-24 16:50:58 +0100

mahfiaz gravatar image

It is a bug. As a workaround you place the cursor at the end of the previous line, press delete and enter and the extra space be gone.

A few more hints: you could copy the equation code and paste that. Also you could write/paste your equation code as pure text, then select it and choose "Insert → Objects → Equation", the text turns automagically into equation. It becomes extra easy when you set a keyboard shortcut to that actions, use Tools → Customize for that, I use F4 for that purpose.

Furthermore, if you happen to have many routine numerical calculations (e.g for engineering), you could use CompPad plugin or you could use Calc to create equation code and later use the "select and press F4 (Insert → Objects → Equation)" trick.

So let's say a is in A1, b is in B1 and the answer is in C1, then you could write into Calc: ="c = a + b = "&A1&" + "&B1&" = "&C1&" mm"

edit flag offensive delete link more

Comments

Ah, thank you. Very helpful. I didn't know about typing equations as pure text and converting them. Thanks! I have since discovered that closing and reopening your document also eliminates the space.

AndrewMiles gravatar imageAndrewMiles ( 2012-05-24 18:10:21 +0100 )edit

@majfiaz, @AndrewMiles -- Do either of you know if (1) This bug has been fixed, or (2) An appropriate bug has been filed? Please post a link to the bug on this question. Thanks!

qubit gravatar imagequbit ( 2013-01-27 20:30:12 +0100 )edit

This one is quite an oldie by now and no, it isn't fixed: fdo#47355

mahfiaz gravatar imagemahfiaz ( 2013-02-18 09:38:51 +0100 )edit

Question Tools

Stats

Asked: 2012-05-24 16:33:02 +0100

Seen: 6,588 times

Last updated: May 24 '12