Ask Your Question
0

Calc text import not working correctly [closed]

asked 2014-01-27 16:57:54 +0200

fldynamatic gravatar image

updated 2016-02-19 03:55:22 +0200

Alex Kemp gravatar image

Hello,

I am trying to import this text file - but it doesn't seem to work correctly.

Can you please help?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-19 03:55:43.328580

Comments

Can you provide more information: Version of LO. Sample data from the file (but no private information). What you've tried so far. Date fields can give mixed results. What type of file or format of the file you are importing -- CSV, TAB, etc.

Rugslug gravatar imageRugslug ( 2014-01-27 17:31:23 +0200 )edit

Hi ,

I'm using LO 4.1.1.2. I have enclosed the file. I tried to import it - so far the best result I have achieved is by ticking the "TAB" "SPACE" and merge delimiters boxes. But even then it is not perfect. Excel seems to handle it fine.

fldynamatic gravatar imagefldynamatic ( 2014-01-28 14:20:57 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-01-28 22:39:37 +0200

m.a.riosv gravatar image

Please verify activating the option for Detect Special numbers, also you can select a column a set up the proper type in column type box. Maybe select properly the Character set and Language can help.

edit flag offensive delete link more

Comments

I did try that but no joy I'm afraid. Excel recognises it as an MS DOS (PC-8) format and translates it well. This is quite critical as it means I will have to upgrade more desktops to Office2013 and I would rather not do that.

Also, the way Excel handles these imports is really nice - you can also during the import join 2 columns making it easy to create a result you desire. How can I request this as a feature in LO?

fldynamatic gravatar imagefldynamatic ( 2014-01-31 12:04:48 +0200 )edit

Please, can you paste here a couple of lines of the CSV file. Of course change the text of any confidential information.

m.a.riosv gravatar imagem.a.riosv ( 2014-01-31 22:17:39 +0200 )edit

Item Number Description Customer Name Order Sch Quantity Required


550116859001 SEALKIT PLUS WASHER 00600109 AGCO INTERNATIONAL GmbH(FR SO645934 Fin 18.0 13/01/14 551101326210032 MOTOR 16.8LC SW.VALVE SNM2 VITON SHAFT SE 00603001 Alexander Dennis Ltd (Prod SO627694 Sch 14.0 13/01/14 550LG32890002 SEALPACK 32890 00600109 AGCO INTERNATIONAL GmbH(FR SO646113 Fin 9.0 14/01/14

fldynamatic gravatar imagefldynamatic ( 2014-02-03 15:06:07 +0200 )edit

I thought I had enclosed the file - but I can't seem to see it - I have copied and pasted the first few lines - but I'm not sure this will help you much - so I have uploaded onto mailbigfile.com . The link is here http://mbf.cc/IfKNUB - it is a text file called mfg9_8.txt. Thanks for any assistance you can offer me.

fldynamatic gravatar imagefldynamatic ( 2014-02-03 15:20:56 +0200 )edit

You can use the 101010 icon to send it as code. Your text doesn't have quotes neither commas, and doesn't seem the space is the separator.

m.a.riosv gravatar imagem.a.riosv ( 2014-02-03 17:12:17 +0200 )edit

Thanks for the tip Mario. The file is a combination of TAB and spaces as delimiters by the looks of things.

fldynamatic gravatar imagefldynamatic ( 2014-02-04 12:26:49 +0200 )edit

Then try using only tabs as separators. If it is a CSV file only one separator must be used.

m.a.riosv gravatar imagem.a.riosv ( 2014-02-04 22:13:50 +0200 )edit

Thanks I tried that earlier - I think I'll have to give up on this unless LO decide to support the MS DOS (PC-8) format and also enable one to merge columns on import like in excel

fldynamatic gravatar imagefldynamatic ( 2014-02-05 10:16:49 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2014-01-27 16:57:54 +0200

Seen: 739 times

Last updated: Jan 28 '14