Ask Your Question
0

Why does Calc ignore cells being formatted as Text [closed]

asked 2014-01-28 01:07:57 +0200

Tom Jones gravatar image

updated 2014-01-28 06:29:55 +0200

Is there any way for Calc to reliably accept all plain text data into cells?

I need to create a table of test results (from Fiddler) where each cell would look like this; 0:00:00.046. I have formatted the cells as text. Calc changes my data, for the example above to 00:00:00:05, perhaps formatting it as Time but I am not sure on this point

edit: note for posterity; pasting the same data copied from Notepad++ does not exhibit this auto-rounding of the number as when the text source is Fiddler. I have raised a bug just in case this changing behavior is not by design ( https://bugs.freedesktop.org/show_bug.cgi?id=74138 )

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-19 04:05:17.117506

3 Answers

Sort by » oldest newest most voted
1

answered 2014-01-28 03:07:41 +0200

Rugslug gravatar image

As you said, Format Cells as text before pasting. If you're pasting, then Paste Special, Select Unformatted Text? If you're typing it in, then mariosv's single quote will force text. When I entered in the value as is, it automatically switched it to time. With the quote it will be text but the cell may still be formatted as a number. It could then be formatted as text.

edit flag offensive delete link more

Comments

Normal paste of the indicated value also appears to retain the text formatting and thus value (at least in v4.1.4.2) however the style of the cell is changed.

oweng gravatar imageoweng ( 2014-01-28 04:19:14 +0200 )edit
1

answered 2014-01-28 01:54:00 +0200

m.a.riosv gravatar image

updated 2014-01-28 01:54:40 +0200

Have you tried with a single quote before data to avoid calc interpreting it as hours?

edit flag offensive delete link more
0

answered 2014-01-28 04:15:55 +0200

Tom Jones gravatar image

Good suggestions, thank you both.

I did a table of tests, which I can't paste or format in here unfortunately. There are two options here. The only fix that I can use (to keep my data unchanged) is that you have to tell Calc twice to do plain text; you have to format the cell as Text, and then do a special paste of Unformatted Text.

Especially considering the source is text only (Fiddler) I find Calc's behavior disappointing; my recommendation to others to try moving off Microsoft Office is that LibreOffice wouldn't include dumb or illogical behavior because it comes from a collective of smart and like-minded people. Text should only be text, it's that simple surely. Quit fiddling with my data :)

The other option is that the 'prepending a quote' suggestion also works, which is great for others reading this.

edit flag offensive delete link more

Comments

Can you export a CSV file from fiddler? Then open the CSV file thru LO. Might give you better/different control over the data. And possibly easier handling of more data.

Rugslug gravatar imageRugslug ( 2014-01-28 04:58:27 +0200 )edit

I have the latest version of Fiddler 4, downloaded today, and LibreOffice 4.1.4.2. Unfortunately Fiddler doesn't do an export of performance data to .csv that I can see (it's a debug tool rather than a performance testing tool , AFAIK), and LibreOffice doesn't take the plain text data in a manner that is intuitive for me. However Ctl-Shift-V gets the job done once you've set the cells to Text format

Tom Jones gravatar imageTom Jones ( 2014-01-28 05:51:35 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2014-01-28 01:07:57 +0200

Seen: 1,755 times

Last updated: Jan 28 '14