Ask Your Question
1

Copying text modifies my documents [closed]

asked 2014-01-28 19:54:12 +0200

ExoDoom gravatar image

This issue happens when I use LibreOffice on Openbox, not on Windows, not on KDE (have not tested it on other environments).

Say I open an odt with Writer. If I select some text and then press ctrl+c, selected text is copied to the clipboard (as it's supposed to be), but document gets modified (if I close it, Writer asks me to save before exit). No actual modifications are made, though. I have not changed the original behaviour of ctrl+c in my ~/.config/openbox/rc.xml (actually, text is successfully copied).

Any ideas?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-19 06:24:23.477898

Comments

What version of LO are you using? Did this occur with previous versions? Do you have the same version of LO in Windows and Linux? Openbox and KDE desktops are in the same machine (i.e., same version of LO)?

carnendil gravatar imagecarnendil ( 2014-01-28 20:00:10 +0200 )edit

I'm using LO 4.1.4.2. Yes, this has always happened since I first installed Openbox some months ago. Same version for Windows and KDE (in KDE I installed the whole libreoffice group, though, while in Openbox I skipped libreoffice-kde4. However, I don't think this should be the problem). Openbox and KDE are in the same machine, but they are in separate partitions (and both of them have access to my data partition).

ExoDoom gravatar imageExoDoom ( 2014-01-29 10:28:20 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2014-02-05 18:34:23 +0200

ExoDoom gravatar image

Confirmed, this bug is due to xfce4-clipman.

edit flag offensive delete link more

Comments

Thanks for reporting back. Did you report it as a LO bug (I can't find one) or is the issue with fxce4-clipman?

oweng gravatar imageoweng ( 2014-02-05 23:38:32 +0200 )edit
0

answered 2014-01-29 01:49:14 +0200

oweng gravatar image

I cannot reproduce this issue under Crunchbang 11 x86_64 (Openbox) running LO v4.1.4.2 for a new document containing basic text. Some documents do display this behaviour if they contain automatically updating content such as macros or links. Under Tools > Options... there are settings to control both:

  • LibreOffice > Security > Macro security section.
  • LibreOffice Writer > General > Update section.

The fact that it only occurs under Openbox would would (to me) point to a difference in setting, especially if the same document can be observed to display this difference in behaviour. Bug fdo#71561 reports the same problem for presentation documents, but I cannot find a similar open bug for Writer documents.

edit flag offensive delete link more

Comments

I'm using Arch x86_64 and have installed Openbox from the official repositories. Settings in those sections are the same in KDE and Openbox.

ExoDoom gravatar imageExoDoom ( 2014-01-29 10:34:00 +0200 )edit

That is odd. I install all the LO packages (mainly because I do a lot of testing and in/un/re-installing) so that is one minor difference. Do you have xfce4-clipman or some other clipboard manager installed? It may be interfering in some way. That is about all I can think of.

oweng gravatar imageoweng ( 2014-01-30 03:04:17 +0200 )edit

Yes, I use xfce4-clipman as clipboard manager in Openbox. I'll try to replace it later, once I'm at home. Hope it solves the problem. Thank you.

ExoDoom gravatar imageExoDoom ( 2014-01-30 12:38:50 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2014-01-28 19:54:12 +0200

Seen: 112 times

Last updated: Feb 05 '14