Why is there a typing lag when using a (unicode) font that includes characters from the Supplementary Multilingual Plane?

asked 2021-02-02 08:03:38 +0200

bithunter2 gravatar image

I am using a Unicode font in LibreOffice Writer Version: 6.4.6.2. If I keep the font in its 'regular' form and type, the characters show on the screen at typing speed, but when I change the font to 'italic' or 'bold' form, and continue typing, there is a lag in the display of the character. I type a few words, then wait (about 2-5 secs) for Writer to display the characters. If I change back to regular form, and type the characters display almost instantly. Is this a bug in LibreOffice Writer for displaying characters from the Supplement Multilingual Plane?

edit retag flag offensive close merge delete

Comments

This is a probably not a LO issue but one either in the OS (which is yours?) or in the font renderer (?). The font may also be the culprit if it contains only the regular variant, in which case italic or bold must be emulated, i.e. computed from the regular variant.

Give mode technical details by editing your question. Answers are reserved for solutions on this site.

ajlittoz gravatar imageajlittoz ( 2021-02-02 09:27:21 +0200 )edit

UTF fonts can be huge collections, I've seen some that are 25 megabytes in size. Your systems specs, and document size can also contribute to performance issues.

AdmFubar gravatar imageAdmFubar ( 2021-02-02 20:04:26 +0200 )edit

What font?
And does it actually include separate Bold and Italic fonts?
Or are you creating fake bold or fake italics?

LibreTraining gravatar imageLibreTraining ( 2021-02-09 21:14:05 +0200 )edit