Ask Your Question
0

Noto fonts (regular) are not displaying some characters in Libre Office (squares instead)

asked 2021-02-08 17:23:28 +0200

brij gravatar image

updated 2021-02-08 19:17:35 +0200

Noto Sans and Serif fonts in Libre Office Writer or Spreadsheets are not displaying '→' sign ("Long rightwards arrow"). Instead of → or ← I get tofu squares, which destroys the purpose of the noto fonts. I'm on ArchLinux, KDE, LO 7.0.4.1. This happens only with Noto Sans regular and Noto Serif regular installed with pacman ([GOOG])(light, mono, black all show the arrow). And this happens only in LibreOffice, not in other text editors. Can anyone help me, please?image description

edit retag flag offensive close merge delete

Comments

You probably have to install the Noto Sans Math font separately. The whole Noto fonts series is not a part of LibreOffice but of Linux, so this isn't really a LibreOffice problem.

floris v gravatar imagefloris v ( 2021-02-08 17:42:44 +0200 )edit

The problem is that I have Noto Sans Math installed and I'm on Linux where I have that whole bunch of various Noto fonts (the majority of which is actually not needed for many users...). The arrows are displayed perfectly well with Noto font in other text editors, but not in LibreOffice. That's why I concluded that it must be a LO problem.

brij gravatar imagebrij ( 2021-02-08 18:26:05 +0200 )edit

Starts rant Well, you should have told that you have that installed, so I wouldn't have to suggest that. End rantSo I installed the font (from https://en.m.fontke.com/font/23070445...) and the arrows show in LO 7.0.4.2, Ubuntu 20.x. It strikes me though that the Math font is very unlike the regular Noto Sans font - its 1 looks very different, its spacing is different and I hate the looks of it. Are we even talking about the same thing?

floris v gravatar imagefloris v ( 2021-02-08 18:59:13 +0200 )edit

Yes, apologies for not providing all info. I'm on ArchLinux, KDE, LO 7.0.4.1. I edited my question to include it. I have NotoSansMath-Regular.ttf (not NotoSansMathGX from the link you gave) in my /usr/share/fonts directory, where all pacman-installed fonts are. I downloaded and installed the font you are referring and nothing changed. I'm not sure I understand what you are saying about the Math font and '1' that looks different. Different from what?

brij gravatar imagebrij ( 2021-02-08 19:14:14 +0200 )edit

The and characters copied from your posting look fine for me with Noto Mono, Noto Sans, Noto Serif, Noto Serif Cond. It may be a problem with a particular font version or whatever. Share a sample document.

gabix gravatar imagegabix ( 2021-02-09 10:28:18 +0200 )edit

It seems the problem was with the Noto fonts package in Arch Linux. I removed it and then installed the google version and everything seems to work now.

brij gravatar imagebrij ( 2021-02-09 14:41:28 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2021-02-09 21:00:03 +0200

LibreTraining gravatar image

Noto Sans and Noto Serif do not have those characters.
If they appear what you are seeing is a fallback font.
Out of the fonts installed by LibreOffice, these have those characters:
DejaVu Math TeX Gyre
DejaVu Sans
DejaVu Sans Mono
DejaVu Serif

edit flag offensive delete link more

Comments

Dear @LibreTraining,

Sorry for cutting in, I am using Fedora 33 Workstation Edition, GNOME Desktop with LibreOffice 7.0.4.2-7.fc33, by default at this time.

Can you please teach me how to list all fonts installed by LibreOffice only ?

lonk gravatar imagelonk ( 2021-02-10 01:56:39 +0200 )edit

This is very interesting. I thought Noto fonts kind of contain all characters and that's why they are so named ("no tofu"). How then would you explain that in all text editors these arrows appear but not in LO? Plus why then they didn't show in LO if I indeed had all these DejaVu fallback fonts installed as well?

brij gravatar imagebrij ( 2021-02-10 11:22:08 +0200 )edit

@lonk - No way to list only those fonts that I know of. Open/extract the install package and you can see the fonts installed with LO. I have looked at it so much I remembered which ones are included when I checked the character availability.
@brij - The no-tofu part of the Noto fonts comes from all the different language fonts, not from one font.
The fallback fonts are configured by LO in a buried config file; I can tell you from looking at the fonts selected, and the order ... it is totally wacko. In the bug tracker somewhere it states where this fallback list came from, but I do not remember. If you look at it some of the fonts selected just make absolutely no sense at all (e.g. Lobster Two). Usually it does include a basic Unicode fallback font at the top of the list; one of which ...(more)

LibreTraining gravatar imageLibreTraining ( 2021-02-25 01:31:24 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-02-08 17:23:28 +0200

Seen: 56 times

Last updated: Feb 09